Ask Your Question
0

Touch keyboard acute accents opens menus instead of inputting

asked 2018-07-05 11:43:48 +0200

brunoboe gravatar image

updated 2018-07-05 11:49:04 +0200

I've been using the Windows 10 touch keyboard to input accented characters ever since I got a laptop without a numberpad, can't do alt codes anymore.

However, trying to put any letters with acute accents into LibreOffice Writer opens up the menus instead of inputting. é opens up the Extension Manager. á opens up the Table menu. I tried removing the ctrl+alt+E shortcut for EM in Customise -> Keyboard, now putting in é opens the Edit menu. I really need to be able to put in these without having to insert a special character every time.

All other accents go in fine (èêëēäàâāãæüùûū etc.). Also not a problem in Calc or Impress, just in Writer.

Using LibreOffice 5.4.6.2 (x64)

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2018-07-09 08:22:34 +0200

Xoristzatziki gravatar image

The problem is definitely related to the kind of virtual keyboard used and what that particular «virtual keyboard» sends to the system, as well as to LibreOffice. Not directly connected to LibreOffice. A "decent" virtual keyboard must be used, but which one is out of scope of this page.

edit flag offensive delete link more
0

answered 2018-07-05 17:51:57 +0200

brunoboe gravatar image

Prompted by @petermau, I did find the English Extended keyboard layout (it's not called International, but it serves the same function). Now I can do the keyboard shortcuts I used to use long ago again, I only learned alt-codes after they stopped working for some reason.

This doesn't solve the issue of what the touch keyboard is doing: changing the layout to Extended doesn't stop the accent input from there opening the menus. But the ALT-GR inputs are much more convenient anyway...

edit flag offensive delete link more
0

answered 2018-07-05 13:52:41 +0200

petermau gravatar image

On my system (linux Mint - En-GB) this would be a system keyboard definition problem, not a Lib~O issue. What language are you using, and what keyboard definition. Using En-US International or EN-GB International, French, German etc. You use the ALT-GR (right alt) key to input your accents, not the numerical keypad. This allows me to type éáấç ÉÁÇ etc.

I use the keyboard command to set up my keyboard. Your system will have something similar.

edit flag offensive delete link more

Comments

My Windows 10 settings in general are for English (United Kingdom). There is no EN-GB International language option, nor is there any option like that for keyboard layout. In LO, the setting is the same, English (UK). In Options -> Language Settings -> Language there is also no EN-GB International option.

Good to know about the CTRL+ALT-GR shortcuts to produce acute accents though, are there equivalent ones for the other types of accent?

brunoboe gravatar imagebrunoboe ( 2018-07-05 17:28:16 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-07-05 11:43:48 +0200

Seen: 21 times

Last updated: Jul 09