Ask Your Question
0

Exported file in odt format from Google Docs, opened in LO: Cannot create proper footnotes in LO

asked 2018-07-05 21:57:47 +0200

swarup gravatar image

I am using Ubuntu 14.04 LTS with LO Version: 4.2.8.2, Build ID: 420m0(Build:2). I have a 250 page manuscript which I have written in Google Docs. It is ready for the final formatting, adding headers and footnotes, and then exporting as PDF for sending to the printer to produce a book. But there are certain limitations in Google Docs due to which final formatting cannot be done there. For example, the header does not permit for having different text on left and right pages, whereas LO has this facility. So I have exported the file from Google Docs into the format odt, and opened the document in LO to complete my formatting.

The problem I am facing is that when I create footnotes now in LO, there is supposed to be at the bottom of the page a solid line above the first footnote which delineates the footnotes from the normal text of the page. That solid line is not appearing. Also, there at the bottom of the page, the number of the footnote is supposed to be set off from the text of the footnote. That is not occurring; rather the footnote number and the footnote text abut each other with no space between them-- unless I manually insert a space.

I have tested this when creating a file natively in LO and it works fine. The problem only arises when I export in ODT format from GDocs.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2018-07-05 23:28:41 +0200

floris v gravatar image

Modify the settings for footnotes in the page styles that you use in your document. You probably only have Default in your document so open the styles list (F11), select the page styles tab (4th from the left), right click on Default, select Modify, then select the Footnote tab and make any changes that you want. If the options are grayed out or you can't make changes for some other reason, please say so.

edit flag offensive delete link more

Comments

Great! I was able to add the solid line and specify how long I want the line to be, as well as how far the line should be from the text above and the footnote below. There is only one issue remaining: There at the bottom of the page, the footnote number should be set off from the footnote text by a few spaces. Or alternatively, the footnote number should appear as a superscript. Either option would work and if both are possible, let me know. Is there a place where these settings are to be found?

swarup gravatar imageswarup ( 2018-07-06 00:11:29 +0200 )edit

(Right now the footnote number is literally touching the footnote text, squooshed up against it.)

swarup gravatar imageswarup ( 2018-07-06 00:13:40 +0200 )edit

The spacing of text from the number inside the footnote is defined by the paragraph style used for footnotes. The style is assigned in ToolsFootnotes and Endnotes....

When you know which paragraph style to modify, you go to that style (usually "Footnote"), and tweak the Before text and First line settings on Indents & Spacing tab - which are used unusually for the footnotes paragraphs.

Mike Kaganski gravatar imageMike Kaganski ( 2018-07-06 04:01:07 +0200 )edit

Alternatively, you tweak the character style used for footnotes (usually that's "Footnote characters") to make them, e.g., superscript. That character style is only applied to the number.

Mike Kaganski gravatar imageMike Kaganski ( 2018-07-06 04:03:57 +0200 )edit

1) To adjust the spacing of text from the number inside the footnote, when I go to Tools -> Footnotes and Endnotes, I do not see any Indents and Spacing tab. There are only two tabs-- one for Footnotes, and one for Endnotes. Within the Footnotes tab, there are no further tabs. 2) To make the footnote number appear as a superscript, within Tools -> Footnotes and Endnotes, under character style I do not see any option for superscript. As mentioned above, I am using LO Version: 4.2.8.2.

swarup gravatar imageswarup ( 2018-07-06 21:23:11 +0200 )edit

You mix up the Footnotes and Endnotes window and the paragraph styles window. I know this is bewildering at first, but styles are a very important feature of LO, it's very important that you master them.

floris v gravatar imagefloris v ( 2018-07-06 22:35:44 +0200 )edit

When I put the cursor at the beginning of the footnote text of one footnote, and then open the format -> paragrapha-> indents and spacing -> first line, and there set change it from 0.0 to 0.2, it indents the first line of the footnote. But it includes the footnote number as well in the indentation. I want to separate the footnote number from the footnote text. Or alternatively, setting the footnote number to superscript would be fine.

swarup gravatar imageswarup ( 2018-07-07 19:51:28 +0200 )edit

Also: The indentation I achieved was for only one footnote-- the footnote where I had placed the cursor. I want to achieve this setting for all the footnotes in the document. Please guide me explicitly which window I need to go to, to make these footnote settings. It is not in the Footnotes and Endnotes window. And the paragraphs window provides a setting for only one footnote paragraph, not all footnote paragraphs.

swarup gravatar imageswarup ( 2018-07-07 19:53:03 +0200 )edit

Please read the documentation on paragraph styles (Help, Wiki and more). Pretty much all of your problems are very basic, and they are fully covered in the documentation. Get back to us when you don't understand something. One hint: Format - Paragraph only affects selected text or the paragraph with the cursor in it.

floris v gravatar imagefloris v ( 2018-07-07 22:16:42 +0200 )edit

I have spent five hours today reading through the WG54, and learned many things. But I could not find where to set the font size for all footnotes, and to set the footnote number as a superscript. Not for one footnote, but for all footnotes.

swarup gravatar imageswarup ( 2018-07-08 02:48:09 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-07-05 21:57:47 +0200

Seen: 95 times

Last updated: Jul 05 '18