Ask Your Question
1

Disable column fill down when bottom right corner of cell is double clicked

asked 2018-07-10 10:12:10 +0200

reddy gravatar image

Hello,

When the bottom-right corner of a cell is double clicked, all the cells below are filled with the value of the cell clicked.

I would like to disable this behavior as it has never helped me and recently resulted in a disaster when I double clicked somewhere without noticing and unintentionally modified hundreds of records. This event had repercussions before the problem was noticed.

Is there a way to remove of modify this behavior ? If I want to fill down a value, I always drag the cell down.

Thank you

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-07-11 04:29:49 +0200

Mike Kaganski gravatar image

updated 2018-07-11 06:20:17 +0200

The function is documented here.

I don't think it's a good idea to introduce an option to disable it. There are potentially countless functions that might hurt if used unknowingly/wrongly. Copy+Paste; Save(As); Drag-fill; Sort; Find&Replace ... to name just a few.

What had happened was unfortunate; but now you know about the tool. Just use it knowingly. Disabling any known feature does not safeguard you against problems when you unintentionally would use a yet-unknown feature - so I don't see a point in disabling what is known.

edit flag offensive delete link more

Comments

While this is not the answer I hoped, it is the correct one. I understand the behavior cannot be disabled. Many thanks for your help, the reference and the insight, very much appreciated.

reddy gravatar imagereddy ( 2018-07-11 10:32:41 +0200 )edit
1

answered 2018-07-10 22:19:18 +0200

erAck gravatar image

I don't get that behaviour, simply double clicking, even on a cursor selected cell on the marked corner handle when the mouse cursor changes to a plus, does not do anything. The handle needs to be pulled down to fill with a series. Otherwise double clicking places the cell into edit mode. Make sure it's not some "helpful" operating system or window manager setting that interferes.

However, stating LibreOffice version and operating system might help in case someone else wants to try..

edit flag offensive delete link more

Comments

I do repro with Version: 6.1.0.1 (x64) Build ID: 378e26bd4f22a135cef5fa17afd5d4171d8da21a CPU threads: 4; OS: Windows 10.0; UI render: default; Locale: ru-RU (ru_RU); Calc: CL

It happens exactly when double-clicking on the corner handle. It fills down the column until the bottom of currently-filled block; so it needs an adjacent column with rows below currently-selected cell. E.g.: fill something to A1:A3 and B1:B7; double-click works in A1-A3 or B1-B2.

Mike Kaganski gravatar imageMike Kaganski ( 2018-07-11 02:27:58 +0200 )edit

Specifically that's ScViewFunc::FillCrossDblClick()

Implemented in i12313; documented in help.

Mike Kaganski gravatar imageMike Kaganski ( 2018-07-11 04:05:24 +0200 )edit

Personally I dislike an idea of multiplying options to disable this or that function. E.g., here. Double-click does a myriad things depending on circumstances. Why disabling one single function? or will we also introduce an option to disable entering cells by double-click? ... And there are myriad ways to break own data. E.g., one can overwrite a file with useful data by mistake; will we disable overwriting?

Mike Kaganski gravatar imageMike Kaganski ( 2018-07-11 04:21:49 +0200 )edit

Ah, you have to have data immediately adjacent to the cell where you double click the handle, otherwise the behaviour is not triggered.

erAck gravatar imageerAck ( 2018-07-11 13:41:20 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-07-10 10:12:10 +0200

Seen: 41 times

Last updated: Jul 11