bookmarks disappear when document closed (after saving)

asked 2018-07-12 04:14:49 +0200

OK, I have a pretty large document, several in fact, hundreds of pages each, so I need lots of bookmarks. Several times running, I entered a lot of them. They are there, and they work. Then I save the document, and when I open it again, almost all of them are gone.

I think I have identified the circumstance which causes this. I also have lots of comments. Most of the places I want bookmarks--significant places in my documents--I have a block of text with a comment attached. To get those, I selected the block of text, then used ctl-alt-C to pop up a (marginal) comment, and type in the text.

Well, I want the bookmarks to be there at the beginning of that block of text, or sometimes at a particular point inside the block. Not a paragraph later (or twenty paragraphs later, sometimes), after the end of the block. But the bookmarks that disappear are the ones that are in those positions. Or, it seems after some testing, anywhere inside the commented block of text.

The bookmarks are there, and I can use them to navigate--until I close and reopen the document!

It was suggested to me that they might still be there, just hidden. I looked in the help (and also googled, uselessly), and found the statement that I can display hidden text this way: "Enable the check mark at View - Hidden Paragraphs". There is no Hidden Paragraphs under View. I'm pretty sure this is a red herring, anyway, because the help talks about variables I used to define the condition for hiding the text, and I didn't do anything like that (and don't understand the explanation of how to do it, either). Help text doesn't match the program. though.

I did find, under Tools - Options - Formatting Aids, three check boxes relating to Hidden Text or Hidden Paragraphs. All of them are now checked, and this makes no difference that I can see. I think those are a red herring, too.

I think this is a bug in LibreOffice. I'd love to be wrong, and find out that there's some simple setting I'm missing. I'm trying to be polite, but I've wasted many, many hours on this--first, in entering and reentering bookmarks, second on trying to figure out what the problem is. I find it hard to believe that no one else has observed this, but it seems not. Am I really the only one who tries to use both bookmarks and comments extensively?

Thank you.

-- Davecat

edit retag flag offensive close merge delete

Comments

I should have said: At the moment, I'm editing on a Fedora system, and the About says: Version: 5.4.6.2 Build ID: 5.4.6.2-3.fc27 CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: gtk2; Locale: en-US (en_US.UTF-8); Calc: group

I move the file back and forth (sneakernet using a flash drive) to a Windows 10 system, also running 5 (and I am pretty sure it's also 5.4). The behavior is the same on both systems, so it doesn't look like and OS issue.

-- Davecat

Davecat gravatar imageDavecat ( 2018-07-12 04:21:22 +0200 )edit

I think this is a bug in LibreOffice.

You are most probably correct.

I'd love to be wrong, and find out that there's some simple setting I'm missing.

There's no such setting to the best of my knowledge.

I'm trying to be polite, but...

... please keep that attitude. We all try to do our best; and there's nothing free or errors. When we stumble upon a bug that affects our work, we are likely to loose patience - which helps no one. Thank you.

Mike Kaganski gravatar imageMike Kaganski ( 2018-07-12 04:23:07 +0200 )edit

In what file formaat do you sav e the file? Docx? If so, try saving in the native format, odt.

floris v gravatar imagefloris v ( 2018-07-12 09:39:38 +0200 )edit