Ask Your Question
0

A dot is automatically changed to an apostrophe in formulas in Calc

asked 2018-07-23 19:29:35 +0100

snowboard975 gravatar image

updated 2018-07-25 21:05:57 +0100

When I try to input a dot in formulas in Calc, it is automatically changes to an apostrophe. For example, I tried to input below formula.

=2.03*2

However, it is automatically changed to below formula and results in an error, Err 509.

=2'03*2

It seems it is related to the decimal separator key because this computer is located in Belgium and comma is typical decimal separator key in this country. However, I set the system language as English, the locale format as English (US), the location as US, the keyboard default language as English. And Libreoffice's option > Language settings are all set to English (US) as below.

User interface : Default English (USA) Locale setting : English (USA) Decimal separator key: Same as locale setting (.) (checked)

This problem is frustrating. This problem does not occur in my other laptop with Windows 10, but it only occurs on my laptop with Windows 7.

How can I solve this problem?

My system and libreoffice's version information is as below.

Version: 6.0.5.2 (x64) Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16 CPU threads: 4; OS: Windows 6.1; UI render: default; Locale: en-US (en_US); Calc: group

Thank you in advance.

edit retag flag offensive close merge delete

Comments

That's odd.. can you enter such number into a cell and it is recognized as numeric number? For example in A1 enter 2.03 and in A2 =SUM(A1) should result in 2.03 not 0.

erAck gravatar imageerAck ( 2018-07-23 20:49:39 +0100 )edit

Yes, I can enter 2.03 in cell A1 and =sum(a1) in cell A2, and cell A2 shows correct answer 2.03. My problem only occurs in a formula, not just a number. If I enter =2.03 in cell A1, cell A2 shows an error, Err:509 because cell A1's content was automatically changed to =2'03

snowboard975 gravatar imagesnowboard975 ( 2018-07-25 21:10:13 +0100 )edit

Does the same thing for me in 6.1.0. This error is a show stopper. already went back to 6.0.6.

Jpgrah gravatar imageJpgrah ( 2018-08-12 17:48:43 +0100 )edit

Please report a bug at http://bugs.documentfoundation.org/

Hopefully someone can reproduce and nail down the circumstances under which it occurs so that it could be fixed.

erAck gravatar imageerAck ( 2018-08-15 13:29:05 +0100 )edit

Thank you for the answers. I have filed a bug report as below.
https://ask.libreoffice.org/en/questi...

snowboard975 gravatar imagesnowboard975 ( 2018-08-16 15:30:31 +0100 )edit

Thanks a lot!

Fwiw, it's tdf#119314

erAck gravatar imageerAck ( 2018-08-16 16:17:22 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-07-25 22:12:58 +0100

erAck gravatar image

Might be some weird AutoCorrect feature is hitting.. try menu Tools -> AutoCorrect Options... -> Options, uncheck Use replacement table and see if that changes anything. If then good please check Format -> Cells.. -> Font, the Language setting, and if you can spot a replacement in Tools -> AutoCorrect Options... -> Replace for that language which could cause this behaviour. If there is any please report back. Thanks.

edit flag offensive delete link more

Comments

Tools->AutoCorrect Options ... -> Options : Use replacement table has already been (i mean "has been" as "was" and also "is") unchecked. Format -> Cells .. -> Font: Language has been set as English (USA). Tools-> AutoCorrect Options .. -> Replace : Language has been set as English (USA). I looked carefully at the list of replacement rules. There is no entry that changes dot to apostrophe in the list. They are just default rules that I did not add or modify anything.

snowboard975 gravatar imagesnowboard975 ( 2018-07-27 15:27:47 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-07-23 19:29:35 +0100

Seen: 66 times

Last updated: Jul 25 '18