Ask Your Question
1

Writer: Formulas missing in output

asked 2018-07-24 18:18:52 +0200

ufo gravatar image

Hi, my current problem: in Build ID: 5.0.6.2-14.el7, I have a document with several math. formulas. These look perfect in the editor, but are completely erased from any form of output (export as jpeg, pdf, png, print preview, print to file/pdf). Switching on or off "Embed fonts in the document" has no impact. I attach a small example document.formula_missing_in_print_and_export.odt and the png formula_missing_in_print_and_export.png it was exported as. The pdf export is not permitted as an attachment here, but looks similar to the png. Would updating help or is this another problem? If the latter it would be very nice if LO threw an error message instead of silently dropping the formulae. ufo

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2018-07-24 21:14:16 +0200

image description

edit flag offensive delete link more

Comments

Thank you for that advise which indeed fixed the issue. However, I had not thought that I need to explicitly activate printing for something which is obviously part of the document content. Now, I have some more formulas in the actual document: is there a way to activate printing for all of them, or do I have to set this for all the formulas individually? Is there a pre-set possible to make (new) formulas printing without explicit activation? ufo

ufo gravatar imageufo ( 2018-07-24 21:39:03 +0200 )edit

Newly inserted formulas should not need explicit activation with default settings. And they don't in my testing (at least with Version: 6.1.0.2, but I used that for very long time and had no issue in previous versions): both using InsertObjectFormula, and using "FN"→F3 autotext. But if you have modified Formula frame style disabling print, then the formulas will indeed not print - which is user error then. Check your document or template maybe.

Mike Kaganski gravatar imageMike Kaganski ( 2018-07-24 23:38:25 +0200 )edit

And yes, that's the style that had been modified (just checked in your test document), so changing it to print will make all objects using that style to follow the change, unless they explicitly override the setting. F11Frame Styles button→right-click FormulaModifyOptions tab.

Mike Kaganski gravatar imageMike Kaganski ( 2018-07-24 23:40:24 +0200 )edit

Thanks again, so, yes seems to be my fault albeit I can't remember to have switched off that default ... Learned something. If anyone dealing with the LO help is reading this: would be nice to see a small hint that this "to print or not to print" option exists and where it can be set / overridden. I have looked and found nothing :-(.

ufo gravatar imageufo ( 2018-07-25 09:50:12 +0200 )edit

If anyone dealing with the LO help is reading this: ...

Well - I also couldn't find a way to get to relevant help page unless already there in UI. So yes - your idea is valid, but... this site is not for bug reports/enhancement request - so if you want something to happen, please file relevant RFE. Helping with fixing that would be even greater! :-)

Mike Kaganski gravatar imageMike Kaganski ( 2018-07-25 11:03:12 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-07-24 18:18:52 +0200

Seen: 120 times

Last updated: Jul 24 '18