Ask Your Question
0

Unable to use Extension TeXMaths

asked 2018-08-05 14:01:57 +0200

Daniel Volinski gravatar image

updated 2018-08-05 17:54:16 +0200

kompilainenn gravatar image

I just installed 6.0.6.2 (x64) on my windows 10 machine. I reinstalled TexMaths-0.46 successfully.

When I try to use TeXMaths to include Latex code from a math application, I click on Equation type: Latex then the button Latex and I get: An error has occurred, please check your TexMaths configuration...

I check the TexMaths configuration: The mandatory paths are correct. When I go to options button I get a LibreOffice Basic debug window with a pop-up saying "Inadmissible value or data type. Index out of defined range." The debug window is open on line 240 major = vstr(0) of file TexMathsTools

What should I do?

Daniel

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-08-05 15:18:34 +0200

RGB-es gravatar image

Latest version of TexMaths is 0.46.1. That version fixes some problems like the one you have: try the newest version to see if it fixes the problem.

edit flag offensive delete link more

Comments

I don't see any TeXMaths version 0.46.1 in

https://extensions.libreoffice.org/ex...

The last one is 0.46 Released May 13, 2018 This is the one I used

Daniel

Daniel Volinski gravatar imageDaniel Volinski ( 2018-08-05 16:11:15 +0200 )edit

It seems the extension page is not updated. See the project page

http://roland65.free.fr/texmaths/inst...

There you'll find the download link at sourceforge

https://sourceforge.net/projects/texm...

RGB-es gravatar imageRGB-es ( 2018-08-05 17:14:23 +0200 )edit

Thanks, I updated TeXMaths to 0.46.1 and also noticed that in the TeXMaths->Configuration->Paths you have to write the path of latex and the command latex itself i.e. it is not enough to write the path to latex. Any way, it is working now!

Daniel Volinski gravatar imageDaniel Volinski ( 2018-08-05 19:32:54 +0200 )edit
0

answered 2018-09-27 17:40:01 +0200

Fred2 gravatar image

THANK YOU!!!!!!!! This was a HUGE help. Changing "/usr/bin/X11" to "/usr/bin/X11/latex" seems trivial, but it wasted a lot of my time. Seems this change could be announced more prominently.
Thanks for finding the solution.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-08-05 14:01:57 +0200

Seen: 904 times

Last updated: Sep 27 '18