Ask Your Question
0

word vs writer: format changes in writer but not in word [closed]

asked 2013-04-16 14:32:26 +0200

vnc786 gravatar image

updated 2015-10-31 04:27:19 +0200

Alex Kemp gravatar image

LO=3.5/4.0 64bit when i copy some data(Data=text with columns+rows) to Writer, the content gets spread to many pages and the same data when pasted to M$ word it gets fit to one page.

how do i overcome this. i have attach screen shot of both writer & M$ word

what i did till now: tried on LO 3.5+ubuntu, LO 4.0.3+win, used all paste special option but no luck.

lo1.jpg lo2.jpg

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-31 04:28:05.972419

Comments

What is the data source? Are you pasting content that is originally in a table? The result in LO looks like it is being pasted into a table in the document. The Paste Special option will treat the pasted content like plain text and not respect cell boundaries i.e., it will try and fit all the content into a single cell.

oweng gravatar imageoweng ( 2013-04-17 13:40:58 +0200 )edit

the content is an Air E-ticket which is in my thunderbird mail body which i am just trying to copy in new document(LO) where as in M$ word copy works fine in new document as u can see in image

vnc786 gravatar imagevnc786 ( 2013-04-24 14:28:41 +0200 )edit

Is the E-ticket a PDF or a HTML table in the email? It seems to me like this is a problem with the handling of HTML tables. Is there an example (HTML table) you can find on the internet that displays the same behaviour when pasting into Writer?

oweng gravatar imageoweng ( 2013-04-28 00:41:32 +0200 )edit

E-ticket is html based & i tried to copy some DATA but the result seems to be same whereas the paste special and normal paste gives the same output but in M$ it pastes proper format eg:http://tinyurl.com/bqwjsm5 i copied data from this site. there might be some workaround to overcome this ..!!

vnc786 gravatar imagevnc786 ( 2013-04-29 06:40:07 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2013-05-02 00:18:24 +0200

oweng gravatar image

updated 2013-05-06 14:08:40 +0200

The WHO table you link (in the comments) pastes fine into a Writer document here using either v3.5.7.2 or v4.0.2.2. Inspecting the code of the table shows it to be a typical plain HTML table with structure:

<table>
    <thead>
        <tr>
            <th>...</th>
        </tr>
    </thead>
    <tbody>
        <tr>
            <td>...</td>
        </tr>
    ...etc...
    </tbody>
</table>

It has a few attributes for some of the elements, but nothing unusual. All I can suggest is: a) the table in your email is malformed; b) the HTML filter in LO may not be handling the particular HTML construction used in your table. Can you have a look at the HTML code in the email? See if has any spanned columns or unusual syntax.

EDIT: As a result of the provided source HTML (third comment below). I had a look at the HTML in the email and there are numerous issues. The structure and form of the code is really not great, which is what I guessed. Here are the main problems as I see them (and as the W3C Validator service reported them):

  • <?xml version="1.0" encoding="utf-16"?>: This initial declaration indicates probably XHTML 1.0 Transitional schema with UTF-16 encoding. I can't see a reason for using UTF-16 encoding and so manually altered this to "utf-8" for validation purposes.
  • DOCTYPE: I said "indicates XHTML 1.0 Transitional schema" because there is no included DOCTYPE statement. The W3C Validator confirms this.
  • Errors: There are 35 errors ad 33 warnings reported, so it is definitely not valid markup. While many of the errors and warnings relate to missing "alt=" attributes and embedded PHP statements, there are several missing end tags and misplaced tags e.g., <td> element immediately after a <table> element. It is basically, rather poor code.
  • Code elegance: The excessive nesting of <table> elements within other <table> elements is ugly. There are six tables within each other in the first 40 lines of code and 29 tables in total. Good code would only have one <table> element and then divide the content as I indicated above: separate head and body areas with rows and cells in each. There are no <thead> or <tbody> elements at all. Web browsers are very forgiving of these types of omissions. LO may not be as forgiving because it has to translate this mess into a valid XML schema.

My (very basically ... (more)

edit flag offensive delete link more

Comments

many thanks for reply !! HTML code in email(thunderbird) is same what you have posted. request you to find 2 attachment which i have created in M$ and LO 4.0 http://temp-share.com/show/KdPf2U5Fhhttp://temp-share.com/show/dPf3aC4HW i have copied data from yahoo mail. can you look the difference in LO which got pasted weirdly

vnc786 gravatar imagevnc786 ( 2013-05-03 09:52:37 +0200 )edit

I had a look at the documents and neither are very pretty in terms of layout, but I can see what you mean about the initial four boxes displaying better in the Word version. Unfortunately, this is likely to be a case of quite poorly defined / structured HTML in the original email, however without the source HTML, there is little else that can be suggested. Even with it we may not be able to suggest a solution, but it may help identify the problem source.

oweng gravatar imageoweng ( 2013-05-04 15:18:09 +0200 )edit

hi..oweng please find the source of mail in case you can find some information about html table http://pastebin.com/LA3FkdSX if you want I can forward the same Email to your email id.

vnc786 gravatar imagevnc786 ( 2013-05-06 07:21:30 +0200 )edit

Thanks for providing the source HTML. I have edited my answer to provide a clear reason as to why it is likely not pasting correctly.

oweng gravatar imageoweng ( 2013-05-06 14:10:22 +0200 )edit

thanks oweng !! i have understood the issue so finally i have to do manually adjustment before giving print

vnc786 gravatar imagevnc786 ( 2013-05-08 14:45:26 +0200 )edit
0

answered 2013-04-18 11:06:37 +0200

It seems like writer is pasting into a nested table. A workaround might be to paste normally and then use the Table to Text function (Table -> Convert -> Table to Text [paragraph]).

edit flag offensive delete link more

Comments

didn't helped that the whole layout/words gets here and there since it is an ticket..

vnc786 gravatar imagevnc786 ( 2013-04-24 14:32:23 +0200 )edit
0

answered 2013-04-20 13:35:02 +0200

jiero gravatar image

updated 2013-05-02 06:19:32 +0200

I think the problem is how do you think:

Whether "retain format" OR "being reformatted" when imported into Document Processor.

Add an option is the only way.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-16 14:32:26 +0200

Seen: 320 times

Last updated: May 06 '13