Ask Your Question
0

What help deb dependencies are needed

asked 2018-08-09 00:00:00 +0200

justlinux gravatar image

I cannot install help files due to unmet dependencies.

edit retag flag offensive close merge delete

Comments

Probably not installing correct Help. See this answer -> libreoffice off-line help

Ratslinger gravatar imageRatslinger ( 2018-08-09 00:33:21 +0200 )edit

It may help to specify your LO version & OS.

Ratslinger gravatar imageRatslinger ( 2018-08-09 04:03:41 +0200 )edit

No I have the correct version, version matches main LibreOffice deb, if it's wrong it was packaged wrong.

justlinux gravatar imagejustlinux ( 2018-08-09 04:11:58 +0200 )edit

KDE Neon based on Ubuntu 16.04 and I downloaded LO 6.1. I have been a user since it was released as Open Office under Sun.

justlinux gravatar imagejustlinux ( 2018-08-09 04:15:03 +0200 )edit

OK - got to be Bug(s). Earlier today I downloaded & installed 6.1.0.3 & help for Mint 18.3 (64-bit deb files). Had no dependency issues with Help install. However, I did not check the help using F1. Just checked & it obtains the on-line help only. Even re-installing Help does nothing. You should check Bugzilla (found here -> Bugzilla and report if not already done by someone else.

Ratslinger gravatar imageRatslinger ( 2018-08-09 04:42:06 +0200 )edit

LO 6.1 now uses an html help. Did you check if the url in your browser is local (file://...) or not (something like https://help.libreoffice.org/latest/e...) ?

JBF gravatar imageJBF ( 2018-08-09 09:33:51 +0200 )edit

@JBF Thank you for the info. Yes, in fact it is the HTML file so I retract my earlier comment regarding this.

@justlinux Based on my v6.1 install, don't know why yours is causing a problem.

Ratslinger gravatar imageRatslinger ( 2018-08-09 16:49:35 +0200 )edit

@Ratslinger Glad you found a solution. It appears there is a greater dependency being called for in the deb file, must have been too tired to catch this: Selecting previously unselected package libobasis6.1-en-gb-help. Unpacking libobasis6.1-en-gb-help (6.1.0.3-3) ... dpkg: dependency problems prevent configuration of libobasis6.1-en-gb-help: libobasis6.1-en-gb-help depends on libobasis6.1-en-gb (>= 6.1.0.3); however: libobasis6.1-en-gb-help depends on libobasis6.1-en-gb (<= 6.1.0.3-3); however:

justlinux gravatar imagejustlinux ( 2018-08-09 18:34:12 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-08-09 19:12:14 +0200

justlinux gravatar image

updated 2018-08-09 19:30:59 +0200

I didn't have the "Translated User Interface: English (GB)" debs installed. I dug deeper and found that it required libobasis6.1-en-gb:amd64 which is part of the interface package. That solved the install issue and I located it under /opt/libreoffice6.1 and the help files were there. I had to change the UI language to English (UK) to get the program to look local for the help files, after that when you press F1 it pulls up the local help file:///opt/libreoffice6.1/help/en-GB in the browser. It works, but I've never had to change the UI language before.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-08-09 00:00:00 +0200

Seen: 52 times

Last updated: Aug 09