Ask Your Question

Unwanted Change to AutoValue Selection in Base Table

asked 2018-08-09 22:02:47 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

My computer is running Ubuntu 16.04 (32-bit), LibreOffice 5.x. I'm reviewing "Filter/Search with Forms (leveraging SubForms)" as a guide, including its links, etc., in an effort to use filtering tables instead of queries. I created a table, set the field ID as the Primary Key and set the AutoValue to "Yes". After saving table, the AutoValue changed from "Yes" to "No". Why is this happening and how can it be fixed? Thank you (in advance).

edit retag flag offensive close merge delete


@3v3rkureus Please do not post as wiki. It helps no one.

You question appears to involve a split DB. If so, what process did you use to create the .odb? If not, what DB is this?

Also, LO 5.x is too general as that includes many versions. Please be more specific.

Ratslinger gravatar imageRatslinger ( 2018-08-09 22:15:28 +0200 )edit

Sorry. Will refrain from posting to wiki. I'm just trying to get the AutoValue to work on any table. I'm using LO Version: I'm trying to recreate the table "starter" using Example_Sport.odb. The table, in creation mode, will note the AutoValue as "Yes" but will not maintain the "Yes" after saving the table. As a beginner, I'm unsure what a split DB is. I'm trying to determine if it's worth continuing Base with my computer enviroment; or to let it go because of the bugs in the prg.

3v3rkureus gravatar image3v3rkureus ( 2018-08-09 23:18:04 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2018-08-09 23:44:26 +0200

Ratslinger gravatar image

Hello@ 3v3rkureus,

You would set a field to AutoValue if the field type is Integer. Only one field in a table can be set to AutoValue and this field will automatically be set to (or at least part of) the table Primary Key.

edit flag offensive delete link more


Ratslinger, Thank you for your response. Sorry for my prior lack of info. I went to "" and downloaded "BH5001-IntroductionToBase.odt - 04.10.16 - 1877 kb". In there is the Example_Sport.odb that I'm trying to replicate. My present table adheres to your response. As noted, problem is maintaining the "Yes" option to AutoValue after saving the table. I also appreciate your answer to my question on "How can I prevent a Base form loosing focus?"

3v3rkureus gravatar image3v3rkureus ( 2018-08-10 04:46:39 +0200 )edit

OK. More info please. Are you working with the sample or designing from scratch? Exactly which table & field are you dealing with? Are you trying to change an existing table or creating? If existing does it have data in it already? So far I have had no problem but I am on Mint 18.3 with LO v6.1.x (64-bit). Your LO version is quite old but I don't remember any problems with that version (albeit I used 64-bit)

Ratslinger gravatar imageRatslinger ( 2018-08-10 05:16:56 +0200 )edit

I designed "sport" table from scratch. Data was entered even though I couldn't set primary ID field's AutoValue to "Yes" just to see how far I'd get w/Base. I created the "rel_starter_sport" and "starter" tables (no AutoValue needed). The form "starter", which includes a sub-form was created & data can be viewed & edited. I am trying to replicate the database, verbatim, where permitted. Many attempts were made to CREATE the "sport" table & saving the "Yes" to AutoValue w/o success. Tnk You

3v3rkureus gravatar image3v3rkureus ( 2018-08-10 05:57:01 +0200 )edit

Jo Rats;omger. Sorry, I wa trying to create the table "starter" vice "sport". It is the "starter" table that requests the ID field to be the Primary Key with the AutoValue set to "Yes". Sorry for the confusion. Thank You.

3v3rkureus gravatar image3v3rkureus ( 2018-08-10 06:06:57 +0200 )edit

Hi Ratslinger, Sorry for my typos at the beginning of my last comment. Guess my brain is getting fried with my old computer and programs.

3v3rkureus gravatar image3v3rkureus ( 2018-08-10 06:09:17 +0200 )edit

Figured you had wrong table before you posted. Did load LO v5.1.6.2 (64-bit). Used .odb sample from post. No problem changing Auto Value once the Relationship settings were removed (data in tables already). No problem with new table either. Only thing left for now is for you to post a sample of your .odb. Normally you can do this in your question(by editing) but don't know if wiki prevents it. If so, find an outside (free avail I'm sure) source to use. Otherwise too much back & forth.

Ratslinger gravatar imageRatslinger ( 2018-08-10 06:30:41 +0200 )edit

Have you tried creating a new table with an Auto Value field? Just a test.

Ratslinger gravatar imageRatslinger ( 2018-08-10 06:38:38 +0200 )edit

Yes. I tried creating new tables in different databases with the AutoValue (AV) set to "Yes". Each time I save the table, the AV option was changed back to "No". I even took the example table, "starters" from the Example_Sport.odb database, deleted each field except for the Primary Key with the AV set to "Yes" and then added the deleted fields back to the table again. The AutoValue option "Yes" was again changed to "No" after I saved the table. Tried variants of the above w/o success.

3v3rkureus gravatar image3v3rkureus ( 2018-08-10 08:14:50 +0200 )edit

I had to edit the file /etc/default/grub to "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash stack_guard_gap=1" to keep my machine from crashing everytime I opened Base. Guess that's the problem when using the 32-bit version of the program. If I had a 64-bit computer, I'd definitely us the 64-bit version as I read there were many few problems. Anyway I appreciated your time, efforts and assistance.

3v3rkureus gravatar image3v3rkureus ( 2018-08-10 08:23:57 +0200 )edit

If I had a 64-bit computer, I'd definitely use the 64-bit version as I read there were fewer problems. Brain got short-circuited again. Above is the correction of my last comment.

3v3rkureus gravatar image3v3rkureus ( 2018-08-10 08:26:53 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2018-08-09 22:02:47 +0200

Seen: 78 times

Last updated: Aug 09 '18