Ask Your Question
2

Automatic update of external links has been disabled [closed]

asked 2018-08-12 15:32:50 +0100

Håkan Wallenthin gravatar image

updated 2020-08-06 22:39:14 +0100

Alex Kemp gravatar image

I get this message when I open a Calc document containing links to other document. I have to update the content by pressing a specific button. It's OK to me but ..

Is there a way to switch disable to activate?

Regards Håkan Wallenthin

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-06 22:39:49.495736

Comments

I have the same problem. My file is created in LO 5, all worked correctly as up until the latest LO6 update. I have not been able to find the solution for the problem so far. Is there a feature in LO 6 introduced that prevents updating external links?

t180819 gravatar imaget180819 ( 2018-08-20 05:52:08 +0100 )edit

I'm also having the same problem. My calc document was created in LO 5. After updating to LO 6.1.0.3 (x64) I'm getting that message when opening linked documents. I can't find a way to turn this on so that it auto updates.

Teemo gravatar imageTeemo ( 2018-09-10 15:46:22 +0100 )edit

I have the same problem with an update from 6.0 to 6.1

NormD gravatar imageNormD ( 2018-10-01 18:18:22 +0100 )edit

I too am having the same issue. The suggested solution did not work for me either.

Gmarie gravatar imageGmarie ( 2018-10-16 22:38:28 +0100 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2019-04-01 12:35:32 +0100

TheHag gravatar image

updated 2019-04-01 13:31:51 +0100

I was having the same problem until I set my local filespace as a trusted location.

Tools - Options... - LibreOffice - Security - Macro Security... - Trusted Sources - Trusted File Locations.

You can get more details via LibreOffice 6.1 help. (The help refers to Writer but the security settings are global throughout LibreOffice.)

Index => update links

Global => updating -- links in text documents

edit flag offensive delete link more

Comments

Thanks Mike, I spotted the URL was local but couldn't remember how I'd got there. I've updated it now.

TheHag gravatar imageTheHag ( 2019-04-01 13:38:34 +0100 )edit
2

answered 2018-10-02 00:38:30 +0100

Steve Pike gravatar image

updated 2018-10-02 00:41:29 +0100

I recently updated to LibreOffice 6.1 and had the same issue of automatic update of external links being disabled. Here is what worked for me:

  1. from Calc drop-down menu select: Tools > Options > LibreOffice Calc > General
  2. under "Updating ... Update links when opening", set the radio button to: Always (from trusted locations)
  3. click OK
edit flag offensive delete link more

Comments

simple and clear! I was messed searching in the "advanced" options... ':-) my +1 goes for you!!

guigonse gravatar imageguigonse ( 2018-11-12 11:16:19 +0100 )edit

Thanks for your answer but this solution doesn't work for me. I still have to do a manual update despite the radio button is set to Always. I have restarted the program and even my desktop but no change.

Swedish Win 8.1 and LO 6.1.3.2

Håkan Wallenthin gravatar imageHåkan Wallenthin ( 2018-11-17 08:02:52 +0100 )edit

same problem in writer 6.1 . i've set the appropriate option in writer>general to always, but when opening a doc with links (like sections from another doc), it still shows that annoying popup. when fixing this, i would also add a checkbox on that initial popup to set that 'always' for all links. (this refers to bug 120736 , which should be extended maybe to all products, not only calc) btw: under edit>"links to external files", the checkbox for automatic update is always grayed out ...

goodguy00 gravatar imagegoodguy00 ( 2018-12-22 15:42:38 +0100 )edit

I have the same problem (Suse Leap 15, LO 6.1.3.2). I have re-installed and set the option for "Update links when opening" to "Always" but it still doesn't work. A possibly related issue is the "Tools>Options>LibreOffice>Security>Macro Security" button doesn't do anything when running in as an ordinary user however it pops up a dialogue box if running as root (still doesn't allow automatic updating of links though).

Mugwump gravatar imageMugwump ( 2019-01-01 16:15:35 +0100 )edit

Your help was great. As someone before, simple & clear.

EJSJr gravatar imageEJSJr ( 2019-04-11 04:36:27 +0100 )edit

This did not solve the problem for me, since I already had Always selected. "Macro Security... - Trusted Sources - Trusted File Locations" as described by @TheHag solved the problem.

RonJohn63 gravatar imageRonJohn63 ( 2020-05-18 04:22:08 +0100 )edit

WAS OR IS THIS EVER RESOLVED

CHEECHBURGER gravatar imageCHEECHBURGER ( 2020-09-08 10:18:40 +0100 )edit

Question Tools

2 followers

Stats

Asked: 2018-08-12 15:32:50 +0100

Seen: 6,276 times

Last updated: Apr 01 '19