Ask Your Question

Base: Form, Date Format Not Matching Table

asked 2018-09-10 01:28:56 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

RE: LO 6.1

I created a report and set dates to format mm/dd/yyyy

When I created an entry Form the date formats are mm/dd/yy

Why? Shouldn't the Form (and Report) date format automatically match the table?

Why does Base make things so difficult?

Dropbox Image of Problem

edit retag flag offensive close merge delete


Your image cannot be viewed.

Ratslinger gravatar imageRatslinger ( 2018-09-10 01:49:14 +0100 )edit

1 Answer

Sort by » oldest newest most voted

answered 2018-09-10 01:47:54 +0100

Ratslinger gravatar image

updated 2018-09-17 21:52:00 +0100

Hello @Tecknomage,

Still can't resist posting as wiki although it only presents hurdles for those trying to answer questions.

Base does not make things difficult. Rather you may find it this way because of its' flexibility. Dates in a table are not stored mm/dd/yyyy or mm/dd/yy but rather as yyyy-mm-dd. What you see in a form or report or most anywhere else is the display format which is chosen by the user. This allows the date to be displayed in whatever format the user needs for that particular occasion.

Just change the property of the control you are using and modify the format to what you want displayed.

Edit 2018-09-19:

You do not change formats for a Form but rather for a control on the form.

To change properties for a date control (as other controls) open the form in edit mode, right mouse click the control and select Control.... Then under the General tab you will find the Date Format:

image description

Select format wanted from the dropdown.

edit flag offensive delete link more


Problem, how do I change the date-display format for a Form? There is no option to do this that I can see for Forms, both Table and Reports have a way to change date format. Right-clicking a Form date field does not display a way to format the date like Table or Reports do.

Tecknomage gravatar imageTecknomage ( 2018-09-17 16:29:14 +0100 )edit

You have to be in form design mode (from the menu Form -> Design Mode). Then right click the element and go to "Control...".

blue gravatar imageblue ( 2020-01-17 01:08:06 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2018-09-10 01:28:56 +0100

Seen: 438 times

Last updated: Sep 17 '18