Ask Your Question
0

Page numbering problem in Writer

asked 2018-09-15 08:16:58 +0100

btpost gravatar image

updated 2018-09-15 08:18:15 +0100

ebot gravatar image

I'm writing a movie script and trying to set up a screenplay template in libre writer.

I have set the character, dialogue, etc. styles and they work fine.

I'm having problems with the page numbering.

A properly formatted screenplay will have a title page with no page number (of course). The second page (which is the first page of the actual text) will also have no page number. The third page will have a page number which should be 2 (in the upper right corner), with the rest of the pages numbered accordingly.

Can anyone tell me how to do this? Because I have tried and tried and I can't figure it out.

I know it's possible because there is a libre writer screenplay template available for download that does it. I'm not using that template because it's extremely deficient in other respects and I can't fix it no matter how hard I try.

Anyone interested can find that template at: http://9timezones.com/scr2.htm. Scroll down and click on "screenplay 8½x11"

I'm using libreoffice 5.4.0.3 on a mac running macOS Sierra 10.12.6.

Much thanks in advance to anyone that can help.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-09-16 16:14:09 +0100

Platterbaff gravatar image

There is more than one way to achieve what you describe. I find the following works with Windows 7/LO 6.0.6, and as far as I know all earlier versions.

1 Put the cursor at the end of your title page. Insert a page break by selecting Insert>Manual Break.

2 This will open a dialogue box. Make sure "Page Break" is checked and enter the name of the page style you will be using for your script (very likely Default), then check the "Change page number" box and set the first page number you want in the box below it. Click on OK.

3 Modify the Default page style to your liking. Make sure this includes "Header on" and that "Same content on first page" is unchecked (but see 5 below on creating a Title Page style).

4 Put the cursor in the header area of your second page, in the position where you want your numbers. Select Insert>Field>Page Number. Your first page number will probably appear, but if some words appear select View>Field Names to toggle between the name of the field and its effect.

Some points to note

5 You can create your own "Title page" page style and change your first page to that. This will give you more freedom to produce a layout that doesn't have a header and won't be affected by changes to the page style used for the rest of your script. If you do this, it seems best to have "Same content on the first page" in the Manual Break dialogue box checked but this doesn't seem to make any difference on my system.

6 If you don't know how to manage page styles read Chapter 8, "Introduction to Styles" in the LO 6.0 Writer user manual. You can download this as a PDF, free of charge, from the LO website's documentation page (https://documentation.libreoffice.org...). To open a list of styles select View>Styles (in Windows F11 should open it too, but I think Macs use a different shortcut). Click on the fourth icon in the row at the top to open the list of page styles.

7 To create a template for future scripts see Chapter 10 of the LO Writer 6.0 manual.

8 You can make a variety of adjustments to the page number position by modifying the style you are using for the text pages (e.g. have odd numbers on the right and even on the left for double sided printing, though to get everything right you might need to insert a blank page for the rear of the title page). You will need to figure out what is right for you.

I hope this helps.

edit flag offensive delete link more
1

answered 2018-09-15 10:39:30 +0100

RGB-es gravatar image

In order to change page formatting and page numbering, you need to use page styles combined with page breaks.

That means you need at least two page styles (one without, the other with, page header) and to change from one style to the other you need to perform an Insert → More Breaks → Manual Break → under "Type" select "Page break" and pick the corresponding style from the drop-down list. There you can also change the page number by checking the corresponding box and selecting the number.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2018-09-15 08:16:58 +0100

Seen: 55 times

Last updated: Sep 16