Ask Your Question
0

Is there a simple way to change the default font(s) for all of LibreOffice?

asked 2018-09-23 20:27:14 +0200

tref gravatar image

updated 2018-09-25 09:04:24 +0200

David gravatar image

This question has been asked numerous times in different ways but I have not found an answer. Perhaps it is there and I missed it but perhaps I missed it because no one has answered the question.

I am NOT asking how to change the default for just Writer nor am I asking how to make a template.

I am no computer guru but since there IS a default font for Calc (Liberation Sans 10), I assume that this default is in some config file SOMEWHERE, probably along with the default font for Writer. Okay. What is that file and where is it? Can THAT file be edited to change the default fonts for both Calc and Writer?


Update (see David's answer below): I appreciate your answer that each module of LibreOffice has its own defaults as I had not seen this point elsewhere. Your instructions regarding Writer were good but those for Calc, while maybe valid on your OS with your version of LO, are not valid for my OS, Raspbian9, and/or version of LO, 5.2.7.2, the latest package currently available for my OS. You write:

With Calc, it appears you need to go directly to the ‘default template’ to set your font choice: Styles > Manage Styles, make sure the ‘Cells’ tab is active, right-click ‘Default’, select ‘Modify’, then set your choice(s) in the ‘Fonts’ tab.

But in my case:

  1. There is no “Cells” tab in Calc but there is a “Cells” choice in the “Format” tab’s drop down menu. Selections made there apply only to the current worksheet – no Default option.
  2. There is no “Styles” tab. The “Styles” choice in “Format” let’s you create a Style from scratch but has no template to follow.
  3. There is no “Manage Styles” in this “Styles” choice nor in the “Format” tab.
  4. I could find no “default template” at all; the choice File>Templates doesn’t refer to Calc templates but to Pi templates; the only “Defaults” was under Tools>Options>LibreOffice Calc and has only number of worksheets in a new document and the name of that/those worksheets.

In light of this, how can I modify the default style/template, including the font, in LO 5.2.7.2’s Calc?

edit retag flag offensive close merge delete

Comments

@tref - I moved your "answer" into your Question, since it provided more information bearing on the question and it wasn't an answer! ;) Hopefully we can get this sorted for you soon. I no longer have the 5.2x series available, but perhaps someone else will.

David gravatar imageDavid ( 2018-09-25 09:05:59 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-09-23 21:12:44 +0200

David gravatar image

These are set in each of the applications. That is, you cannot (so far as I know) make one change of "default font" for every application in the LibO suite. So, the main ones are Writer and Calc.

Writer

You can set a default for Writer in (Win/Linux) Tools > Options... > LO Writer > Basic Fonts (Western). Note that in Mac OSX, this is under the application name in the menu bar: LibreOffice > Preferences ⌘, > etc.. Set your prefered fonts there.

Note, however, that LibreOffice works very much with "Styles" and "Templates", and these override the selection made in the application default. For more about this, see the relevant section of the online help pages.

Calc

With Calc, it appears you need to go directly to the "default template" to set your font choice: Styles > Manage Styles, make sure the "Cells" tab is active, right-click "Default", select "Modify", then set your choice(s) in the "Fonts" tab.


To show the community your question has been answered, click the next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-09-23 20:27:14 +0200

Seen: 163 times

Last updated: Sep 25 '18