Ask Your Question
0

Which Java JDK & JRE is needed for LibreOffice 6.1

asked 2018-09-27 11:26:44 +0200

Tonyb gravatar image

updated 2018-09-27 12:30:58 +0200

ebot gravatar image

Just updated to LibreOffice 6.1.0.3 on MacOS 10.13.4 Trying to open a MySQL database via JBC Connection-- org.openoffice.comp.drivers.MySQL.Driver Using Advanced Java Options Oracle runtime (Java 11) mysql-connector-java-5.1.22.bundle.jar

Error message "The driver class 'com.mysql.jdbc.Driver' could not be loaded"

Any ideas?

MacOS High Sierra 10.13.4 MacBook Pro (15-inch, 2016) LibreOffice Version: 6.1.0.3

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-09-27 16:39:17 +0200

Ratslinger gravatar image

Hello,

You don't state if this was a working connection prior to the LO upgrade. If so, what version of LO was working before?

Mac OS needs Java JDK installed - JRE is not sufficient. Since JDK 11 was just released, and it may work without a problem, it would not be unusual for it not to work with LO. In that case, install JDK 10 or even JDK 8.

Not certain about the connector you state. You should be using a connector from MySQL - Connector/J v8.x is the latest.

edit flag offensive delete link more

Comments

Thanks for the quick and correct answer. Now using JDK 11 and MySQL - connector J v8.x

Tonyb gravatar imageTonyb ( 2018-09-28 02:18:47 +0200 )edit

Can you please explain How to add the connector to LO. I tried through Extension Manager, but was not successful. Thanks

jorengo gravatar imagejorengo ( 2018-11-28 16:47:22 +0200 )edit
Ratslinger gravatar imageRatslinger ( 2018-11-28 17:13:47 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2018-09-27 11:26:44 +0200

Seen: 410 times

Last updated: Sep 27 '18