Ask Your Question
0

numpad not working in Persian language

asked 2018-10-03 09:22:46 +0200

yousef gravatar image

Hello all i am using Persian(Farsi) language that is RTL language. my problem is Numpad keys not working when changing layout from English to Persian. it just works as home,pg dn,pg up and so on. num lock is on. is there any setting for this or it is a bug? i am using linux mint and Libroffice Version: 6.0.6.2 Build ID: 1:6.0.6-0ubuntu0.18.04.1

edit retag flag offensive close merge delete

Comments

You wirte: "num lock is on", really?

ebot gravatar imageebot ( 2018-10-03 10:18:52 +0200 )edit

yes, it is. Numpad works when language is English but not for Persian

yousef gravatar imageyousef ( 2018-10-03 22:55:14 +0200 )edit

Do you have tryed "num lock" switch "off"?

ebot gravatar imageebot ( 2018-10-04 06:27:17 +0200 )edit

yes but still the same. today I found that it seems there is a problem with Linux Mint today i noticed that when language is set to persian i am not able to write any number in port number in firefox network setting. its very confusing. just not in port number but in IP address it works

yousef gravatar imageyousef ( 2018-10-04 09:46:38 +0200 )edit

I have the exact same problem.

Ariya gravatar imageAriya ( 2019-05-14 01:34:57 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-09-08 14:39:27 +0200

moahear gravatar image

image description

image description

edit flag offensive delete link more
0

answered 2018-11-04 00:21:11 +0200

einpoklum gravatar image

The X windows keyboard management mechanism (xkb) has a layout option to use one of the keyboard LEDs to indicate which layout is active. If this is enabled in your layout, you could be seeing NumLock on whenever you're in Persion keyboard layout, and off when you switch to English.

To see if this is the case, use the setxkb command, as follows:

$ setxkbmap -query
rules:      evdev
model:      pc105
layout:     us,il
variant:    ,
options:    grp:alt_shift_toggle,grp_led:scroll

This is what I get on _my_ system, which has Hebrew and US-English layouts. Do you notice the grp_led:scroll option? This means that when I'm in Hebrew, my Scroll Lock LED is on. If in your layout you see something like grp_led:num, then my suspicion is correct. You can then use the UI for keyboard layout management to disable this option and use the NumLock LED as it was originally intended.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-10-03 09:22:46 +0200

Seen: 78 times

Last updated: Sep 08