Ask Your Question
0

Calc XLSX shows "=FALSE()" and MS Office shows "FALSE"

asked 2018-10-03 16:24:01 +0100

IKAROS gravatar image

updated 2018-10-03 18:14:48 +0100

Bug:

Calc opens a XLSX, showing "=FALSE()" in the same cells every other XLSX editor (including MS Office) shows "FALSO" (my Windows 10 is in English configured to the Portuguese formats).

Seems like Calc forgot to recalculate the formulas when opening the XLSX file.

Shared on my Google Drive: https://drive.google.com/file/d/1FGVS... (you need to download, Google shows it fine)

Note: The XLSX was not created or edited on Google. I'm using Google for upload purposes only. I tested the uploaded file an Google didn't modify it in any way.

LO About box: Version: 6.1.2.1 (x64) Build ID: 65905a128db06ba48db947242809d14d3f9a93fe CPU threads: 8; OS: Windows 10.0; UI render: default; Locale: pt-PT (pt_PT); Calc: group threaded

edit retag flag offensive close merge delete

Comments

Google apps are notorious in creating bad docs, where they mark cells as "text" where there's other data. We add workarounds for that from time to time, but it's a pain to break code to allow another broken app to continue producing shit.

Mike Kaganski gravatar imageMike Kaganski ( 2018-10-03 16:35:06 +0100 )edit

I shared on Google Drive, but it's just a coincidence (I should have chosen other file sharing service). The XLSX was created elsewhere.

My point is that it's a well formatted XLSX (AFAIK) that displays well in every other spreadsheet except LibreOffice Calc.

IKAROS gravatar imageIKAROS ( 2018-10-03 16:58:49 +0100 )edit

Please try opening id after downloading from your share. Because I did, and it shows 0 for me with 6.1.2.1. Now I don't know if that's an artifact of your sharing (when Google could modify it somehow), or a difference in our LO settings/versions, or ...

By the way, you failed to tell your LO/OS version.

Mike Kaganski gravatar imageMike Kaganski ( 2018-10-03 17:24:01 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-10-03 18:39:08 +0100

IKAROS gravatar image

FOUND THE PROBLEM:

Sometime last week when checking the LO settings, I activated the Options => LibreOffice Calc => View => Formulas ... and I totally forgot about it. I'm dumb.

Sorry for wasting your time.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-10-03 16:24:01 +0100

Seen: 76 times

Last updated: Oct 03 '18