Ask Your Question
0

Need help installing LibreOffice

asked 2018-10-04 10:05:17 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi Need help installing LibreOffice. I am getting the message "The programme wont start because api-ms-win-crt-string-l1-1-0-dll is missing from your computer. I have installed all available updates and it still comes up with the message. Thanks. Andrew

edit retag flag offensive close merge delete

Comments

What is your Windows version (please use winver command to get version and build)? What version of LibreOffice are you installing (full MSI filename please)?

Mike Kaganski gravatar imageMike Kaganski ( 2018-10-04 10:12:53 +0200 )edit

I'm not a tech, I think these are what your asking for?

Windows is Win 8 Ver 6.3 (build 9600) 2013 and LibreOffice_6.0.6_Win_x64.msi

Justandy gravatar imageJustandy ( 2018-10-04 12:49:24 +0200 )edit
1

Thanks. And one more question: do you have Avast Antivirus installed prior to installing LibreOffice? Just today I discovered that Avast installs some system libraries in a wrong way, which breaks proper detection and installation by LibreOffice. The workaround for you is simply installing a Microsoft update package Windows8.1-KB2999226-x64.msu from https://www.microsoft.com/en-us/downl....

Mike Kaganski gravatar imageMike Kaganski ( 2018-10-04 12:57:44 +0200 )edit

I currently have Bitfender, although I had Avast before.

Justandy gravatar imageJustandy ( 2018-10-04 13:14:13 +0200 )edit

... which means, that you had installed Avast there prior to installing LO (even though you removed it)... ok. Please try the workaround I mentioned, and report here if that succeeded please.

Mike Kaganski gravatar imageMike Kaganski ( 2018-10-04 13:18:13 +0200 )edit

Hi Mike, the workaround worked perfectly, I am very grateful, thank you.

Justandy gravatar imageJustandy ( 2018-10-05 20:54:13 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-10-05 21:13:13 +0200

This is tdf#119910, which is not a LibreOffice bug, but is caused by Avast antivirus messing with incorrect installation of MS UCRT libraries. I have already made changes to our installer to workaround problems of that kind; and in future versions, it will always try to "fix" UCRT when installing (while currently it tried to detect if UCRT is already present on system, thus being fooled by cheating software like Avast which only installed part of the library).

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-10-04 10:05:17 +0200

Seen: 96 times

Last updated: Oct 05 '18