Ask Your Question
0

Writer - Tools -- Macros -- Run macro causes crash

asked 2018-10-05 12:58:20 +0200

mrodent gravatar image

OS: Linux Mint MATE 19

Whatever version of LO I install (I've tried 6.1 and 4.x in particular) I find that whenever I go Tools --> Macros --> Run this causes an immediate crash of the program.

I can go Tools --> Macros --> Edit macros ... and press the green triangle to run a macro - the macro then runs OK.

I can't set (for example) a hotkey to run a macro: any attempt to do this in the Tools --> Customise --> Keyboard -- LibreOffice Macros also causes an immediate crash of the program when I try to select one of the items under "LibreOffice Macros"

What's strange is that there seems little evidence of other people experiencing this very much.

I have tried with both OpenJDK and Oracle JDK selected.

edit retag flag offensive close merge delete

Comments

Isn't that tdf#108619? it could be that because of 32-bit... and then simply disabling Java in advanced options could help.

Please don't forget to revisit this and notify if this helps, to allow others to benefit from this.

Mike Kaganski gravatar imageMike Kaganski ( 2018-10-05 13:04:03 +0200 )edit

Thanks! Well, from my first experiments it appears that this is a "hobbled" workaround: Tools --> Options --> LibreOffice --> Advanced: uncheck "Use a JRE". When I then try to run a macro it doesn't crash, but says "you have to switch on a JRE for this", and then "restart now or later?". So I say "later"... and it then proceeds to run the macro. But you then have to uncheck "Use a JRE" after each time you run a macro! Makes me wonder why there seem so few people having this problem...

mrodent gravatar imagemrodent ( 2018-10-05 17:14:51 +0200 )edit

You don't need to agree to enable despite the question, because it's a wrong message, and in reality, you don't need to enable JRE for that. I believe it's just because you have some Python modules registered. See this question for details.

Mike Kaganski gravatar imageMike Kaganski ( 2018-10-05 17:26:50 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-12-10 12:55:50 +0200

wimduk gravatar image

I have exactly the same problem in Linux Mint 19 XFCE, I will try the workaround and give my feedback

edit flag offensive delete link more

Comments

Implemented the solution and it works fine for me.

During testing the solution I have seen the message a number of times,

I am using a main macro who calls a number of sub macro's, and after implementing the main macro under a function key I do not get the message anymore.

Regards, wimduk

wimduk gravatar imagewimduk ( 2018-12-10 16:37:58 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-10-05 12:58:20 +0200

Seen: 121 times

Last updated: Dec 10 '18