Draw extremely slow on pages with tables

asked 2018-10-05 18:12:21 +0200

patrickfrog gravatar image

Hello,

I am experiencing an issue with LibreOffice Draw. If I add a table onto any page, operations when that page is selected become extremely slow (e.g. selecting, moving, editing text, etc...). When I click on a cell in the table to edit it, it takes about 5 seconds before I am able to edit the cell's contents at which point typing is extremely slow. As long as I am not working on a page with a table, this is not an issue.

LibreOffice Version: 6.1.2.1 (x64) Build ID: 65905a128db06ba48db947242809d14d3f9a93fe CPU threads: 8; OS: Windows 10.0; UI render: GL; Locale: en-US (en_US); Calc: CL

Any ideas as to what could be causing this issue?

edit retag flag offensive close merge delete

Comments

Did you tried to increase memory reserved for LibreOffice under Tools → Options? You should write down default values for just in case and then you try to play with those numbers but I can't guaranty anything. Report back after trying this memory increase trick.

Kruno gravatar imageKruno ( 2018-10-08 22:12:15 +0200 )edit

I doubled the values for org.openoffice.Office.Common/Cache DrawingEngine/OLE_Objects, Graphicmanager/TotalCacheSize, ObjectCacheSize, GraphicmemoryLimit, and GraphicAllowedIdleTime however interacting with tables doesn't seem to have gotten any better. Just for reference, my machine has 32GB of RAM so I should not be running out of memory.

patrickfrog gravatar imagepatrickfrog ( 2018-10-08 22:40:29 +0200 )edit

One last thing I would to is backup user profile and then delete it. If you're not happy with result, restore from backup. Try here

Kruno gravatar imageKruno ( 2018-10-12 20:18:36 +0200 )edit