Ask Your Question
0

How do I have Writer open with a blank doc as default?

asked 2018-10-07 05:31:34 +0200

BarryinCA gravatar image

updated 2018-10-07 17:28:20 +0200

It currently opens with recent files and I'd like to change it. Thanks in advance. EDIT- LO= 6.0.6.2., Windows 10 on desktop.

edit retag flag offensive close merge delete

Comments

What is your OS? The essential data like

The Writer icon is pinned to my taskbar. I want it so when I click on the icon it opens with a blank doc instead of images of my recent docs, which it now shows

should be edited into your question along with version info, because shell integration heavily implementation depends upon OS/WM. And anyway, each and every tech-related question at any site asks for version info.

Mike Kaganski gravatar imageMike Kaganski ( 2018-10-07 09:39:50 +0200 )edit
  1. What OS are you running (Windows 7, Windows 10, Mac OSX (number or name), Linux (what distro), Android?

This question is easy to answer for many OS (windows 7, Mac, ). Some versions of windows get a little more complicated, and some versions of Linux need more information.

just.mikey gravatar imagejust.mikey ( 2018-10-07 16:44:17 +0200 )edit

Yes, forgot to add that. I am running 6.0.6.2. LO on a desktop with Windows 10. Thanks. Btw, I don't have this problem with LO Calc. In 'Start' I right-click on LO Calc pin it to my taskbar and when I click on it a new sheet opens up. Not so with Writer.

BarryinCA gravatar imageBarryinCA ( 2018-10-07 17:08:11 +0200 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2018-10-07 06:41:52 +0200

Ratslinger gravatar image

Hello,

Using Open will default to opening an existing document with your default directory chosen. Instead, from the menu choose File->New->Text Document.

Additionally in my Mint system there is a item for Writer with command of libreoffice6.1 --writer %U which opens a 'blank' document.

edit flag offensive delete link more

Comments

I don't want it to open to an existing document. The Writer icon is pinned to my taskbar. I want it so when I click on the icon it opens with a blank doc instead of images of my recent docs, which it now shows. Yes, I can go to file>new>text but that's a lot of unnecessary steps.

BarryinCA gravatar imageBarryinCA ( 2018-10-07 09:07:13 +0200 )edit
0

answered 2018-10-07 09:48:23 +0200

Mike Kaganski gravatar image

It depends upon OS.

On Windows, there are separate launcher executables for each respective component, like swriter.exe, which do just what you want (in a nutshell, it runs soffice.exe --writer for you, which creates a new Writer document); and the executables allow you to simply create shortcuts for them. Also, you may create such a shortcut yourself, with the cited command-line argument.

On Linux, I believe, there's no binaries for the task, so it might be shell scripts that run such a command line, which means that one could pin the launched app to a taskbar, but actually have plain soffice/libreoffice command pinned. One would need to find (or create) the shell script or other kind of shortcut with required command line, and pin it, instead of generic one.

edit flag offensive delete link more

Comments

I am sure you are correct but it seems like there should be a much easier way. Btw I had no problem with LO in previous versions, and I could be mistaken but I seem to recall an option which allowed me to open up to a blank doc (the shortcut you speak about), but I can't find it here. Functionally I compare it to your browser asking you what page you want to start with when you open it. It should be a 'one-click' option.

BarryinCA gravatar imageBarryinCA ( 2018-10-07 17:24:30 +0200 )edit
0

answered 2018-10-07 09:26:55 +0200

ebot gravatar image

updated 2018-10-07 09:27:25 +0200

Go once to the File>New>Text document menu. In the sidebar, customize the Style / Paragraph Style template to your liking or create a new "Paragraph Style". Also check the "Page Template". If all settings meet your needs, select File>Document Templates>Save As Template... from the menu. In the "Save as template" dialog box, select a name. And put a checkmark under "Save as default template" and save. The next time you call Writer, your saved template should open.

edit flag offensive delete link more

Comments

Thanks. I had already tried that to no avail. FYI I have to select a category of template to save it under and saved it under 'My Templates'.

BarryinCA gravatar imageBarryinCA ( 2018-10-07 17:18:53 +0200 )edit
0

answered 2018-10-10 19:50:36 +0200

BarryinCA gravatar image

Fyi I found the problem and fixed it. In 'Start' I right-clicked 'LibreOffice 6.0' and went to 'Writer' and saved it to my taskbar. Then when I opened 'Writer' on my taskbar my opening page was images of recent docs, which I did not want (I wanted it to open to a blank doc).

Going back to 'Start' I right-clicked 'LibreOffice Writer' under 'Most Used' apps and saved that application to my taskbar. When I opened it up it went directly to a blank doc.

Don't know why one application would open to recent docs and one would open to a blank doc. Maybe it is LO or maybe it is my computer (it never happened before though with previous LO versions). It may be worthwhile to look into it if there are more complaints about it.

At any rate, thanks again for the suggestions.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-10-07 05:31:34 +0200

Seen: 61 times

Last updated: Oct 10