Ask Your Question
0

LibreOffice on Mac - text flow faulty when mixing English and Hebrew [closed]

asked 2018-10-16 15:24:57 +0200

Nisim761 gravatar image

updated 2020-08-18 16:40:05 +0200

Alex Kemp gravatar image

I am using MacBook Pro with macOS 10.13.6. I have installed LibreOffice 6.0.6. image descriptionI am typing in both Hebrew and English. The text indentation is set from right-to-left, but the flow is faulty. How can i fix it?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-08-18 16:40:17.710723

Comments

It could help if you explained what is faulty, most people have no clue about Hebrew RTL, let alone mixed with English LTR flow.

erAck gravatar imageerAck ( 2018-10-16 16:28:42 +0200 )edit

Thanks for the quick reply. The problem is that the order of the english parts of the sentence is wrong. also, the question mark on the 2nd line should be in the end of it (that is, on the left side of the line), but instead it is in the beginning of it (on the right side). When someone is trying to read what i wrote, as it appears in the screenshot i added, it doesn't make any sense.

Nisim761 gravatar imageNisim761 ( 2018-10-17 07:34:22 +0200 )edit

I don't see anything wrong with "the order of the english parts of the sentence". There is only the word LibreOffice which looks correct to me.

The period and question marks at the beginning of the sentences indeed look wrong and might be worth filing a bug if it's reproducible, please attach a short sample document that reproduces it.

erAck gravatar imageerAck ( 2018-10-17 14:48:39 +0200 )edit

I guess you missed the word "mac". I actually wrote that i am using LibreOffice on a mac machine, but as you can understand, writing from right to left, it came out wrong. Also, of course, the words that are in English are not in the correct places in the sentence.

Nisim761 gravatar imageNisim761 ( 2018-10-17 15:45:51 +0200 )edit

Yes I missed the word mac, but still, as you didn't say what exactly is wrong and what you typed in which sequence and what you expect to be displayed I can't tell anything further. Anyway, if it is a bug then I still suggest to file it as bug report with detailed description and a proper test case sample document attached.

erAck gravatar imageerAck ( 2018-10-17 20:37:36 +0200 )edit
1

Just opened a bug (120669). Thank you for your kind help.

Nisim761 gravatar imageNisim761 ( 2018-10-18 07:41:26 +0200 )edit

Thank you! Just linking here tdf#120669

erAck gravatar imageerAck ( 2018-10-18 21:32:33 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-10-17 09:50:10 +0200

ajlittoz gravatar image

This may not be the definitive answer because I have no experience with mixed RTL-LTR, only with mixed languages.

In mixed languages context, the key to successful interpretation by LO is correct "categorisation" of segments, i.e. making Writer aware of the current language. This is done with styles.

I would recommend this method because I don't know the internal behaviour of Writer viz. the Unicode properties (RTL/LTR) of individual characters in a sentence sequence.

Usually, you have a "main" language and a "secondary" language (it is really uncommon to have text where both languages have equal importance in a paragraph). Consequently, you configure the language for your paragraph style in Font tab, Language drop-down menu to be the "main" language. Or you do that on Default Style paragraph style so that it cascades down to all other paragraph styles.

You then define a set of character styles, derived from Emphasis, Strong Emphasis et al., for the "secondary" language (again in the Font tab).

The inconvenient of the style method is you must assign a character style to any "foreign" run and revert to character Default Style at the end of it. The advantage is spelling and grammar checkers work fine.

The case of punctuation is more difficult because punctuation is "auto-adaptative": it becomes LTR in LTR context and RTL in RTL context. Consequently, I'd recommend to include punctuation in the "secondary" run if it inherently belongs in this run and to omit it if is part of the "main" run.

Once again, this only a clue and I'd be glad to have some feedback.

edit flag offensive delete link more

Comments

Thank you very much for the details answer. It looks very troublesome to do so each time i write \ edit a document, as for each document i use a different language as the "main" one, hence using a different indentation (RTL \ LTR). I sure hope there is a better solution, as so far i can't type my \ edit documents my documents on my Mac..

Nisim761 gravatar imageNisim761 ( 2018-10-17 10:12:49 +0200 )edit

Attributing text portions with languages is only necessary for spell-checking and thesaurus and the like. RTL/LTR are script properties (here Hebrew vs Latin) and should result in proper directions when mixed. ie. the LibreOffice is LTR and the Hebrew text is RTL. Period and question mark have weak directional properties, meaning the direction depends on the surroundings, I guess something goes wrong in that context.

erAck gravatar imageerAck ( 2018-10-17 14:52:51 +0200 )edit

The good news (for LibreOffice) is that this issue reproduces also using Pages (an app from the AppStore). But, of course, it is bad news for me.

Nisim761 gravatar imageNisim761 ( 2018-10-17 15:47:20 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2018-10-16 15:24:57 +0200

Seen: 137 times

Last updated: Oct 17 '18