Ask Your Question
0

Writer uses 100% cpu for documents created from a particular template

asked 2018-10-16 19:49:44 +0200

keylevel gravatar image

updated 2018-10-16 19:53:23 +0200

I have a Writer document template that I use for reports.

Running with 6.0.6.2 (and various previous versions) under macOS (El Capitan and High Sierra) is ok for a while (minutes), but after a while the CPU goes to 100%, even when Writer is not being used (including when it is in the background).

I _only_ see this with documents created using this template.

Any ideas what within the template could be causing this?

I can recreate the template, but it is complex with a lot of styles, so I would rather only have to do this as a last resort.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-10-21 23:20:21 +0200

LibreTraining gravatar image

LibreOffice can be really slow and go high CPU when embedding fonts.
I kept having documents which were grindingly slow until I realized the template had embedded fonts.
Turned-off embedded fonts in the documents.
Turned-off embedded fonts in the template.
The delay opening or saving was much reduced.

You may also be seeing this when auto-save is saving the document.

If you must have embedded fonts, do it as a last step.

.

edit flag offensive delete link more

Comments

Thanks for the pointer, but I'm sure that's not the issue I'm seeing. General performance is not an issue, even when this problem shows. Something is just spinning in a loop, the only real consequence being that my laptop battery runs down very quickly!

I have upgraded to 6.1.2.1 in the past few days and have not seen the issue since, so it's possible that the cause has been fixed. I'll keep an eye on things and see how it goes.

keylevel gravatar imagekeylevel ( 2018-10-22 12:04:53 +0200 )edit
0

answered 2018-10-18 01:15:18 +0200

debtfree gravatar image

Hi - Apart from several styles what else can you tell us about the Template? This might help with either its the template or something else? :) if you find a fix yourself please also post here to help others. Thanks.

edit flag offensive delete link more

Comments

Good question. I don't think there's anything special about it - character, paragraph and page styles, Open Sans as an embedded font and a custom colour setting. It does have some fairly complex (but small) table structures that are used to position content within headers/footers.

I have also used files created with this template under Windows and not noticed the same issue.

keylevel gravatar imagekeylevel ( 2018-10-18 09:28:04 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2018-10-16 19:49:44 +0200

Seen: 65 times

Last updated: Oct 21 '18