Ask Your Question
0

Firebird Migration: Form-Based Filters Don't Work

asked 2018-10-19 17:48:50 +0200

sdritchey gravatar image

After migrating an existing ODB database to Firebird with the new migration assistant in LO 6.1.2 on MacOS, when I open my Form to view the database and attempt to perform a search using a Form-Based Filter I cannot complete the search.

I can click on the Form-Based Filter and the pop-up Filter Navigator appears and I am able to select my criteria (tested a few check boxes). Then I click Apply Form-Based Filter and I simply get the first record of all in alphabetical order. The navigation is greyed out and my Table Control scroll box is blank.

Any thoughts on what may be the issue?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-10-19 18:24:07 +0200

Ratslinger gravatar image

updated 2018-10-19 18:32:06 +0200

Hello,

Have checked multiple forms and subform using Form based filter and all work without a problem.

Then tested specifically with checkboxes. When selecting this say as check is ON, the comparison is set to field = 1 and the problem you specify shows up. If, however, you edit this comparison to field = TRUE then the filtering works without a problem. Use TRUE, FALSE & IS NULL.

Wouldn't call this a migration problem but rather just a Firebird problem.

edit flag offensive delete link more

Comments

Just tested the Form-Based Filter with field=TRUE in place of field=1 and indeed it now works. Also tested the number fields and text fields and all appears to work ok. Thank you. Moving forward, what is the best way to address this? My database and form makes extensive use of checkboxes for fast searching, and it will be quite tedious to manually change the "1" to "TRUE" for each criteria. Any way to set this to always be 1=TRUE and 0=FALSE either in the table, the form designer, or other?

sdritchey gravatar imagesdritchey ( 2018-10-19 19:48:06 +0200 )edit

File Bug Report

Ratslinger gravatar imageRatslinger ( 2018-10-19 20:03:37 +0200 )edit

Done, see Bug 120713

sdritchey gravatar imagesdritchey ( 2018-10-19 20:17:23 +0200 )edit

That's good but as stated in answer it isn't a migration problem. It's more a Firebird SQL situation. Happens in Firebird Server connection also.

Ratslinger gravatar imageRatslinger ( 2018-10-19 20:29:50 +0200 )edit

Bug title edited to remove 'Migration'.

sdritchey gravatar imagesdritchey ( 2018-10-19 20:38:59 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-10-19 17:48:50 +0200

Seen: 41 times

Last updated: Oct 19 '18