Ask Your Question
0

LVM size in Linux avoiding to open documents in Libreoffice?

asked 2018-10-23 23:00:54 +0100

flavio.mesquita gravatar image

updated 2018-10-25 14:33:25 +0100

I'm having an issue while trying to open documents with Libreoffice writer, these documents were working fine up to a week ago, everytime I try to open a document now it gives error: problem opening file

If I try to create a new one, it creates, but gives this error: error creating files

I tried to update the Libreoffice package didnt solve, tried to completely uninstall and install the latest version didnt solve either. Checked the permissions for the user are ok, so i decided to look at the disk space. It gives me the following messages:

[root@localhost ~]# df -h

Filesystem           Size  Used Avail Use% Mounted on
devtmpfs             3.8G     0  3.8G   0% /dev
tmpfs                3.8G   18M  3.8G   1% /dev/shm
tmpfs                3.8G  9.8M  3.8G   1% /run
tmpfs                3.8G     0  3.8G   0% /sys/fs/cgroup
/dev/mapper/ol-root   48G   28G   20G  59% /
/dev/sda7           1014M  444M  571M  44% /boot
/dev/mapper/ol-home   23G  1.9G   22G   9% /home
tmpfs                766M   92K  766M   1% /run/user/1000

[root@localhost ~]# fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes, 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0xeb1feb1f

Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048    26626047    13312000   27  Hidden NTFS WinRE
/dev/sda2   *    26626048    26830847      102400    7  HPFS/NTFS/exFAT
/dev/sda3        26830848   457055465   215112309    7  HPFS/NTFS/exFAT
/dev/sda4       457056254   625141759    84042753    5  Extended
/dev/sda5       457062400   457816063      376832   83  Linux
/dev/sda6       457818112   459915263     1048576   83  Linux
/dev/sda7       459917312   462014463     1048576   83  Linux
/dev/sda8       462016512   625141759    81562624   8e  Linux LVM

Disk /dev/mapper/ol-root: 50.5 GB, 50524585984 bytes, 98680832 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mapper/ol-swap: 8321 MB, 8321499136 bytes, 16252928 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mapper/ol-home: 24.7 GB, 24666701824 bytes, 48177152 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

[root@localhost ~]# pvs
PV         VG Fmt  Attr PSize  PFree
  /dev/sda8  ol lvm2 a--  77.78g 4.00m

So, if there is available space as seen with the command df-h, why with the command pvs it says the /dev/sda8 has only 4M free? I'm working with other programs in the same directory without problem. Tried to change permissions, putting 777 to everything, still no luck.

[flavio@localhost ~]$ ls -l
total 40
-rw-rw-r--.  1 flavio flavio  392 Sep 26 08:00 assessm_mod2.sql
-rw-rw-r--.  1 flavio flavio    1 Sep 22 16:10 assessm_mod.sql
-rw-rw-r--.  1 flavio flavio 1688 Oct 24 11:43 audit_proj_bloco.sql
-rw-rw-r--.  1 flavio flavio 8984 ...
(plus)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-10-25 09:08:56 +0100

ajlittoz gravatar image

updated 2018-10-25 14:42:51 +0100

When you create an LVM volume, the corresponding disk space is allocated on the physical disk filesystem so that no other activity on the computer will "borrow" from it and damage LVM processing. This is why fdisk shows the partition as "full" because fdisk only considers the filesystem on the physical disk.

pvs scans inside the OS-filesystem allocated file to report what's happening in the LVM layer and reports the LVM usage.

LO is compatible with ANY filesystem known to the OS. I'm working with LVM without problem. LO accesses files through high-level interface and the OS translates this into low-level primitives.

That said, the error messages alludes to insufficient user rights. You should check the permissions of the directory into which you create your files and the directory above. Check also which user/group owns the directories and the files. You may also bump into SELinux access control restrictions.

If you still can't solve the issue, edit your question (do not use an answer) to provide more info about ls -l or ls -lZ for SELinux check.

EDIT (after your question edition)

File permissions did seem to be correct in your home directory. I suppose your documents are stored in Documents/ directory. Have you checked it?

Note: it is not a good idea to add "x" permission on files because it makes them executable. Remove "x" from your .sql "and" .log "files.*

edit flag offensive delete link more

Comments

@ajlittoz I save everything under Documents, just creating new subfolders under it. Is it possible that something that I installed on the computer changed Libreoffice permissions? It is installed under group/user: root/root, but as my Documents folder and everything under it has permissions to write and read and execute for owner, group and others, it should work. On the last week I have installed Netbeans, Gfortran compiller, Intel fortran compiler, and GCC compiller.

flavio.mesquita gravatar imageflavio.mesquita ( 2018-10-25 15:34:08 +0100 )edit

@flavio.mesquita: it's perfectly OK to install packages under root. LO doesn't change permissions; it is dependent on the system: if access is enabled r/w, LO can read and write according to OS rules (using first user permissions, then group then others). Installing compilers has no impact on user (at least in principle) unless you explicitly change settings.

Check along LO private user directory in ~/.libreoffice/ and below.

ajlittoz gravatar imageajlittoz ( 2018-10-25 17:58:08 +0100 )edit

@ajlittoz: LO has the same privileges as the other programs that are under /opt [flavio@localhost ~]$ cd /opt [flavio@localhost opt]$ ls -l drwxr-xr-x. 4 root root 34 Oct 11 10:19 cwp drwxr-xr-x. 19 root root 4096 Aug 27 15:54 datamodeler drwxr-xr-x. 13 root root 4096 Oct 10 19:10 intel drwxr-xr-x. 7 root root 4096 Sep 20 12:03 libreoffice6.1 drwxr-xr-x. 4 root root 48 Sep 20 12:14 LibreOffice_6.1.2.1_Linux_x86-64_rpm

flavio.mesquita gravatar imageflavio.mesquita ( 2018-10-25 19:39:55 +0100 )edit

The ones below it: [flavio@localhost opt]$ cd libreoffice6.1/ [flavio@localhost libreoffice6.1]$ ls -l -rw-r--r--. 1 root root 1501936 Sep 20 12:12 CREDITS.fodt drwxr-xr-x. 3 root root 4096 Oct 23 09:59 help -rw-r--r--. 1 root root 430288 Sep 20 12:12 LICENSE -rw-r--r--. 1 root root 946493 Sep 20 12:12 LICENSE.fodt -rw-r--r--. 1 root root 586363 Sep 20 12:12 LICENSE.html -rw-r--r--. 1 root root 5026 Sep 20 12:12 NOTICE drwxr-xr-x. 7 root root 80 Oct 23 09:59 presets

flavio.mesquita gravatar imageflavio.mesquita ( 2018-10-25 19:48:10 +0100 )edit

drwxr-xr-x. 7 root root 80 Oct 23 09:59 presets drwxr-xr-x. 10 root root 16384 Oct 23 10:00 program drwxr-xr-x. 2 root root 26 Oct 23 10:00 readmes drwxr-xr-x. 31 root root 4096 Oct 23 10:00 share

flavio.mesquita gravatar imageflavio.mesquita ( 2018-10-25 19:49:28 +0100 )edit

@flavio.mesquita: I meant the LO-private directory in your home directory. This is where LO store user information, profile and settings. If it can't access it, things go really bad. Pay attention to the dot preceding the name; it makes the directory invisible to ls -l. You need ls -al to see it.

ajlittoz gravatar imageajlittoz ( 2018-10-26 10:44:26 +0100 )edit

@ajlittoz: Ok, it was under /.config/libreoffice . It seems ok, anyway I changed the permissions on this folder and all subfolders, still doesnt work. I really dont see what can be going wrong. If it not a permission it is some folder that is full. [root@localhost ~]# pvscan PV /dev/sda8 VG ol lvm2 [77.78 GiB / 4.00 MiB free] Total: 1 [77.78 GiB] / in use: 1 [77.78 GiB] / in no VG: 0 [0 ] What I dont understand is that if the system is full, why other applications keep runn

flavio.mesquita gravatar imageflavio.mesquita ( 2018-10-26 13:12:49 +0100 )edit

@flavio.mesquita: I compare with my computer. Your ol is full. Try to delete unused files or move some to other virtual volumes. Maybe LO requirement in temp files is rather high.

ajlittoz gravatar imageajlittoz ( 2018-10-26 13:19:47 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-10-23 23:00:54 +0100

Seen: 35 times

Last updated: Oct 25 '18