Ask Your Question

When exporting to pdf, links with å ä ö characters become changed

asked 2018-10-31 19:25:10 +0200

Patrik gravatar image

When Exporting to PDF, links with å ä ö characters in name becomes changed to <e5>, <e6> and similar This causes these links not working, links without these characters works fine. I cannot change the names, how do I get the exported links to work correctly?

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted

answered 2018-11-01 09:16:03 +0200

ebot gravatar image

This is probably mainly because of the fact that another font is selected for the PDF. You can embed the fonts in the File>Properties menu, there in the "Font" tab. Just put the check mark. Attention, LO can slow down. So use only if necessary.

edit flag offensive delete link more

answered 2018-11-01 12:20:51 +0200

Patrik gravatar image

It did not work embedding fonts, the problem still remains. I choose export to PDF, checks convert links to pdf targets and Export URL relative to file system Links without åäö ÅÄÖ works fine, but links with these characters does not work.

The error message for example for a link to c:\examplepath\KÅR.pdf is: c:\examplepath\K<c5>R.pdf File not found

Links in original odt file linking to KÅR.odt is working.

edit flag offensive delete link more


  1. This is not an answer to your question, but rather a comment to @ebot's answer. Please use Answer only to provide answers (something mentioned above the Answer box in red).

  2. Please file a bug, and provide a sample ODT to allow reproducing. I assume there is actually a bug there, where we don't properly encode the URL when exporting.

Mike Kaganski gravatar imageMike Kaganski ( 2018-11-01 12:41:05 +0200 )edit

answered 2018-11-01 18:29:31 +0200

petermau gravatar image

I do not have a problem saving a file, either as Untitledåäö.odt or exporting it as Untitledåäö.pdf using my Linux-Mint system as they are all valid UNICODE characters. ä å æ in unicode are E4, E5 and E6.

You do not tell us your operating system and version, language setting, keyboard language and language for LibreOffice. I wonder if your problem is that of your file manager? Can you rename an existing file, using your file manager, and use the same characters? How did you select the characters when creating the file name.

If it was a font problem, I would expect to have a substitute character for each character, not the hex code.

The more information you give us, the more we can try to help.

edit flag offensive delete link more


The wording of OP seem wrong. IIUC the filenames in links inside documents become corrupt. Furthermore, it might simply be that we write "proper" Unicode characters into the links inside PDFs (just as they are stored in ODF), but shouldn't do that: when we store Unicode names in links in ODF, LO itself makes necessary conversions when user activates the link; but when exporting the link, we rely on PDF software doing that.

Mike Kaganski gravatar imageMike Kaganski ( 2018-11-01 18:53:20 +0200 )edit

answered 2018-11-01 19:28:35 +0200

LibreTraining gravatar image

This is an LO bug which you should report.
This is not a font issue.
LO embeds the fonts in the PDF whether the document is set to embed fonts or not.
Plus I examined the embedded fonts in a PDF editor and to check the link text and all look OK.

LO is encoding the characters.
I tested your example link in LO x64 on Windows 7.
When exported KÅR became K%C3%85R.
Opened the same test ODT file in Word 2016 and exported to PDF - the link is correct.

So this is an issue which should go in the bug tracker.


edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2018-10-31 19:25:10 +0200

Seen: 764 times

Last updated: Nov 01 '18