Ask Your Question
0

Can not activate the factory for org.libreoffice.report.pentaho.Report JobFactory$_SOReport JobFactorye

asked 2018-11-03 02:08:58 +0100

mquinzi gravatar image

Dear community,

Since last night I'm getting following error when opening Reports in LibreOffice: "Can not activate the factory for org.libreoffice.report.pentaho.Report JobFactory$_SOReport JobFactory"

This happened suddenly and I don't find any reason why. I'm running Ubuntu-Mate 16.04 was using the LibreOffice version 5 which came with this distro, but now I upgraded to latest version of LibreOffice 6.1.2 in the hopes that it will resolve that problem, but it didn't.

Did anyone experience the same issue, and maybe fine the reason/solution for it.

Your help is much appreciated

edit retag flag offensive close merge delete

Comments

Hello,

Try resetting your user profile -> LibreOffice user profile

Another cause is usually a missing dependency, but you state it happened suddenly. This missing dependency would be wrongfully deleting something or an update missing something.

Ratslinger gravatar imageRatslinger ( 2018-11-03 02:36:36 +0100 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2018-11-12 12:34:36 +0100

updated 2018-11-12 12:43:14 +0100

The answer that worked for me was found here Essentially remove the version that is causing the issue and install version 6.0.7 from the libreoffice site It worked fine, reports reappeared, thankfully.

edit flag offensive delete link more
0

answered 2018-11-08 15:06:49 +0100

I am having the same issue ("Can not activate the factory for org.libreoffice.report.pentaho.Report JobFactory$_SOReport JobFactory") on Ubuntu 18.04 with LO 6.1.3.2, which just got upgraded in the libreoffice/ppa repo.

Reports are being displayed in Ubuntu 18.10 with LO 6.1.3.2, with the "Label" issue described above.

Everything runs just fine in 16.04 with LO 5.2.

edit flag offensive delete link more

Comments

Hello,

This is NOT an answer. Please use add a comment instead!

Can confirm problem using Ubuntu Mate 18.04 & LO PPA v 6.1.3.2

Deleted that & loaded TDF version & all worked OK.

Your 18.10 issue is completely separate & have seen nothing on this.

Ratslinger gravatar imageRatslinger ( 2018-11-08 16:57:06 +0100 )edit

Thanks. I removed LO 6.1.3.2 which came from the ppa, and snap installed libreoffice from TDF (version 6.1.2.1). Now the reports are loading, the only issue left being all labels are marked as "Label" instead of their value.

MrEgg964 gravatar imageMrEgg964 ( 2018-11-10 08:35:26 +0100 )edit
0

answered 2018-11-03 03:39:36 +0100

Ratslinger gravatar image

Hello,

First, please do not use an answer for responding. If not enough room in a comment, either use multiple comments or edit the original question and note the edited information.

Next, v6.1.2.1 has a bad bug for Report Builder. All labels in the report come out with the word "Label". This is to be fixed in v 6.1.3 soon to be released.

It does appear something on the Ubuntu system got corrupted. First thing I would try is to create a NEW report & see if that works. If not, my choice would be to start over with LO. Wipe it out completely & rename the user profile so a new one is created. The most recent LO with a working Report Builder is v6.1.0.3. After this try running the reports. Hopefully, whatever was wrong did not corrupt them. If so, possibly working backups are available.

edit flag offensive delete link more

Comments

Thanks for the suggestion and information. On my Ubuntu system version 6.1.2.1 was not working at all for reports. I tried on Windows with the same version, and it showed up with lots of "Labels" as you have mentioned already. I then did some more research and already found a link to version LibreOffice_6.1.3.2_Linux_x86-64_deb I downloaded and istalled this version which seems to work fine

mquinzi gravatar imagemquinzi ( 2018-11-03 07:19:55 +0100 )edit

But some of the reports still cannot be opened, error message is now: General Error the document could not be opened. Since I found an older backup where all the reports are working I'm fine. I guess for anyone who has trouble opening reports, make sure you are using version 6.1.3.2 or newer Thanks to everyone again for helping much appreciated

mquinzi gravatar imagemquinzi ( 2018-11-03 07:24:47 +0100 )edit
0

answered 2018-11-03 03:13:38 +0100

mquinzi gravatar image

Dear Rtslinger, thank you very much for your suggestion. I launched LibreOffice Base in Safe Mode, but also in Safe Mode I still had to same error happening. In the meantime I moved the database file to a Windows 10 machine, where it used to work. I usually update the database on a different computer (Ubuntu) and then transfer it back to the production machine running Windows 10. It usually doesn't give me any trouble, but I noticed, that also on the Windows 10 computer some of the Reports work and some it states that it cannot be opend, but it doesn't give the extended error message like I get on Ubuntu. On my Ubuntu machine all the Reports are getting the above mentioned error, non of the reports work anymore, but they used to. I'm wondering if some system updates I recently installed could have caused this issue, but I'm not sure. Uninstalling version 5 and installing version 6.1.2.1 doesn't resolve the issue either.

Hope there might be some other suggestions, thanks

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2018-11-03 02:08:58 +0100

Seen: 210 times

Last updated: Nov 12