Ask Your Question
0

When I create a new document with the Windows right click menu the document does not have the formatting of the default document.

asked 2018-11-06 22:21:26 +0100

Mithel gravatar image

Using File Manager in Windows to create a new LibreOffice writer document the document does not pick up the default template formatting.

This used to work with OpenOffice.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-11-06 23:32:50 +0100

peterwt gravatar image

If you use the right click context menu to create a new document then the default template is not used. The template used is in Program Files/LibreOffice(n)/share/template/shellnew/soffice.odt.

edit flag offensive delete link more

Comments

Thank you! This works! Although replace "Program Files" with whatever path you installed LibreOffice.

Mithel gravatar imageMithel ( 2018-11-06 23:45:42 +0100 )edit
0

answered 2019-01-05 21:08:16 +0100

Bugmanmd gravatar image

so how do I fix that? I tried just to open the soffice.odt, change the paragraph styles, change the font, then save it in that folder.

But still if I make a new document by right click, new document, then open it, it has a default "preformatted text" format, not any of the changes that I specify.

Please tell me how to make a new document that uses my default template.

edit flag offensive delete link more

Comments

Did you restart LibreOffice?

LibreTraining gravatar imageLibreTraining ( 2019-01-06 01:44:39 +0100 )edit

The template path is defined in registry, under HKEY_CLASSES_ROOT\.odt\LibreOffice.WriterDocument.1\ShellNew. Typically, a value of C:\Program Files\LibreOffice\share\template\shellnew\soffice.odt is set there for FileName. You may check, and if different, either change to your preference, or modify the correct template.

And please, don't ask questions using Answers. Put whatever necessary to your own question.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-06 08:38:55 +0100 )edit

Sorry - new to this type of forum. thanks - I see that tdf#120822 explained the issue, as you pointed out in another post, for anyone else that may need it.

thank you!

Bugmanmd gravatar imageBugmanmd ( 2019-01-07 05:35:04 +0100 )edit

The tdf#120822 is not the same bug.

Tyco72 gravatar imageTyco72 ( 2019-02-21 15:45:38 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-06 22:21:26 +0100

Seen: 203 times

Last updated: Jan 05