Shapes become messy after reopening the document with Writer

asked 2018-11-09 18:41:42 +0100

gimpo gravatar image

Hallo,

today again the same problem. I usually add arrows, lines, dotted circled over my images to put in evidence some things while writing my manuals. With no apparent reason, after saving and opening again the same document some shapes are disappeared, located in a different position, not rotated as when I saved the doc, not skewed, etc. Also, sometimes the shapes just go in the background, behind the image.

Today, before saving:

Today, after reopening the doc:

In this cases the only way to restore the original document is to erase the odd shapes and draw again them all from the scratch. Honestly, using Writer in this way is becoming quite frustrating. Even doing a little modification of the text for a typo put me in anxiety state, because I know that something could be changed by simply opening the file. So every time I have to check all pages to see if all of the illustrations are ok.

This problem was always with me since more than one year. I've regularly applied all the updates, but not new version has solved this bugs.

Any help?

Version: 6.1.2.1 Build ID: 1:6.1.2~rc1-0ubuntu0.16.04.1 CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; Locale: en-US (en_US.UTF-8); Calc: group threaded

edit retag flag offensive close merge delete

Comments

I had the case. My workaround is to do all editing in Draw, group the elements together and paste the resulting block into Writer. If problem persists, I can use "Paste special" to force conversion to a single picture.

I agree it is a real inconvenience.

ajlittoz gravatar imageajlittoz ( 2018-11-09 19:01:35 +0100 )edit

In which file format do you save?

ebot gravatar imageebot ( 2018-11-09 19:15:33 +0100 )edit

ajlittoz, what if you have to apply a little modification to your drawing? Do you save a distinct .odg file with all the drawings? I'm trying to do the same now and I have a big drawback: I cannot crop the image that I usually use as background... :( :( EDIT: by saving the draw as a bitmap the crop-problem is gone. Mmmmmh... that could be a nice workaround, But I have to maintain two files now: .odt + .odg

gimpo gravatar imagegimpo ( 2018-11-09 19:22:36 +0100 )edit

Yes I save the file containing all schematics as .odg. I found by experience it is more reliable. This compensates for having two files (or more with the specific template). After all, when I use a master document, i have many more files. My "working unit" is a directory, not an individual file.

The crop problem rings a bell in my head, but I don't remember how I solved it because I didn't want to lose the advantages of vector format.

ajlittoz gravatar imageajlittoz ( 2018-11-09 20:56:42 +0100 )edit