Ask Your Question
0

can;t won;t don;t aren't highlighlighted as errors.

asked 2018-11-10 18:40:28 +0100

Stewpot gravatar image

A lot of words with apostrophes in them can be typed with a semi-colon instead, such as those above. They aren't highlighted as errors. Can this be adjusted in the settings for writer?

edit retag flag offensive close merge delete

Comments

Can, won and don are legal English words which are followed by punctuation. The spelling checker does not flag single-letter words, considering they are symbols or abbreviations.

Remember the spelling checker works only on the "shape" of words (excluding punctuation). Apart from the fact you have no space around the semi-column, the sequence is accepted by the simple algorithm.

The work around would be to create AutoCorrection entries.

ajlittoz gravatar imageajlittoz ( 2018-11-10 19:23:32 +0100 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2018-11-11 21:12:42 +0100

Stewpot gravatar image

updated 2018-11-12 17:20:52 +0100

Thanks for the replies. I understand your explanations. However, Word corrects them automatically. Type in 'don;t' and it becomes 'don't'.

Of course, I can live with that anomaly; Writer is free and there are aspects of it that I think are superior to Word. But it would be nice if something similar could be down in Writer.

From my understanding, 'Auto-correct' would only work if 'don;t' was highlighted as an error.

Thanks to BigRai - I've done it and, yes, it works.

Tools, AutoCorrect, AutoCorrect Options. I hadn't been aware of that.

edit flag offensive delete link more

Comments

Auto-correct works fine in these cases (just tested).

BigRAl gravatar imageBigRAl ( 2018-11-12 12:09:27 +0100 )edit

Please suggest as an enhancement: Help>Send Feedback...

EasyTrieve gravatar imageEasyTrieve ( 2018-11-17 04:42:18 +0100 )edit

Also the correct place for comments here are in comments, not in answers.

EasyTrieve gravatar imageEasyTrieve ( 2018-11-17 04:43:01 +0100 )edit
0

answered 2018-11-11 16:23:42 +0100

BigRAl gravatar image

updated 2018-11-11 18:26:19 +0100

Answer deleted - incorrect - apologies.

edit flag offensive delete link more

Comments

I think the problem here is they are not flagged as errors. The built-in grammar tool flag them, but only suggest to add a space after the semicolon. As @ajlittoz said, the words are valid and the spell checker just skip them

RGB-es gravatar imageRGB-es ( 2018-11-11 17:31:40 +0100 )edit

I read the OQ too quickly. Thanks for correcting me @RGB-es. I have edited my answer.

BTW, the Answer editor does not honour Markdown "strikethrough" (using ~~). Is there a trick to it?

BigRAl gravatar imageBigRAl ( 2018-11-11 18:29:24 +0100 )edit
0

answered 2018-11-10 18:51:27 +0100

RGB-es gravatar image

Try reporting the problem to the project that maintain the English dictionaries.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-10 18:40:28 +0100

Seen: 79 times

Last updated: Nov 12