Ask Your Question
0

Decimal Separator Change

asked 2018-11-15 21:12:39 +0200

Infernalz gravatar image

updated 2018-11-16 14:05:18 +0200

erAck gravatar image

Hello,

our ERP system exports currency references with dot values, on which can't be used SUM function - returns 0. Even if i change it from Windows local settings to be dot instead comma Libre Office still can't SUM values.

The language settings for Windows and Libre are Bulgarian(and must stay that way), the "Same as local settings" check in Libre seems not to do anything at all. The only way i found is if Locale Setting is set to USA, Default currency is Default - BGN and Date acceptance patterns are copy paste from Bulgarian, but changing 3 fields for 300+ PCs is really not an option.

Is someone faced this issue ?

edit retag flag offensive close merge delete

Comments

Sounds like your values end up as text content in cells, not numbers. How are the textual values imported to Calc? CSV file?

erAck gravatar imageerAck ( 2018-11-16 00:28:46 +0200 )edit

The values are copy/paste from the ERP, but if i open new sheet and format the cells to numbers manually and put numbers manually still SUM returns 0.

Infernalz gravatar imageInfernalz ( 2018-11-16 07:34:19 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-11-16 14:04:32 +0200

erAck gravatar image

Applying a number format to a cell does not change the cell's content or its type, i.e. text stays text. Either pre-format the cells with a number format of a locale that has the desired . dot decimal separator (e.g. en-US) before pasting the clipboard content, or for how to convert existing text to numbers see this FAQ.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-15 21:12:39 +0200

Seen: 356 times

Last updated: Nov 16 '18