Ask Your Question
0

No tables appear when creating labels

asked 2018-11-17 22:09:35 +0200

Justine gravatar image

When I want to create labels, I am able to select the database, but the drop down menu for "Table" is empty, although I do have a table in that database. The same happens for any of my databases when I select them. They are all registered, I have updated LO, deleted and re-registered the database... Nothing seems to do the trick. This is on Mac High Sierra 10.13.6. I would appreciate any advice as I cannot imagine writing almost 100 addresses for Christmas by hand 😬

Screenshot of empty drop down menu

edit retag flag offensive close merge delete

Comments

@Justine Sorry but do not have an answer. Have not seen this before & can't duplicate. Can offer this - try resetting the user profile. Possibly something went awry. See this post -> LibreOffice user profile.

Ratslinger gravatar imageRatslinger ( 2018-11-18 21:36:42 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-12-02 10:57:01 +0200

Motorfingers gravatar image

updated 2018-12-02 16:31:30 +0200

You need to add a database with a table of values (columns in a CSV or .ods file, names in first row). I find that for the Labels window to see the database, it must be added through the Insert -> Field -> More fileds (Ctrl-F2) window, then open a Text file and insert any field. Then that database will appear in the Labels window.

When you first select the new database in the Database box, it will take a few seconds for it to load and the Table an Database field boxes to respond.

NOTE: I'm here because I loaded a database while working to get the Labels function going, but find that the original out-of-date database appears no matter what I try - deleting databases, renaming .ods files, deleting .odb files found anywhere on the computer, nothing deletes the old unwanted data or loads the new corrected data. Be sure that your label data is in final form before you load it.

EDIT: When you are in the Labels window, on the Labels tab, under Table: highlight Selected, NOT List, and you will get your corrected database. If you highlight List, you will get everything ever loaded with the labels presented. With the Selected table, you get the updated Database field when you insert fields in the label.

edit flag offensive delete link more

Comments

@Motorfingers Not certain of where some of your problems lie. The only thing I've needed to do to get a database visible in Labels is to register it. Just tested again & can delete, add or modify records and those changes are reflected in the Label process when generating. Also, as can be seen in the screen in the question, there is no Selected or List on the Labels tab.

Possibly you are on an older version. Mine is v6.1.3.2 and has worked this way for many versions.

Ratslinger gravatar imageRatslinger ( 2018-12-03 06:20:27 +0200 )edit

@Ratslinger - I solved my problem by discovering that I must use the Selected table.

@Justine Still puzzled as to why your Table list is empty. Perhaps the CSV file is not formatted properly? I suggest that you load it into a Calc spreadsheet page, make sure that the table is OK there, then use the Calc spreadsheet .ods file as your database. That worked for me, and Selected was available from the Table window. Then, the column headings were available in the Database field window.

Motorfingers gravatar imageMotorfingers ( 2018-12-03 09:54:55 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-17 22:09:35 +0200

Seen: 83 times

Last updated: Dec 02 '18