Ask Your Question
0

Erratic footnote spacing

asked 2018-11-21 17:46:25 +0100

cantrip gravatar image

updated 2018-11-21 17:48:00 +0100

Apologies if this has already been answered - did some digging and couldn't find anyone with this exact problem (but I'm happy to be directed to an answer!).

So I love the little tab that automatically gets inserted in between a footnote number and text. The problem is, it's not consistent, sometimes even within the same document. Check this out: image descriptionimage description

Footnote 99 is all clean and nice, but footnote 100 refuses to conform. Worse, LO doesn't seem to recognize the problem - as you can see in the upper left corner, the style is "Footnote" in both cases, so switching the style to "Footnote" doesn't change anything.

If anyone's figured out how to solve the problem, I'd sure be grateful.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-11-21 18:22:09 +0100

It is perfectly consistent, and footnote 100 conforms. Here is what you get if you overlay your two images:

image description

You may see that the text is aligned to the same "tab" (horizontal position) in both cases. It's the width of the number that gets wider in case of 100, which reduces the gap.

edit flag offensive delete link more

Comments

Thank you! I didn't realize that!

cantrip gravatar imagecantrip ( 2018-11-21 18:27:28 +0100 )edit
0

answered 2018-11-21 18:20:01 +0100

ajlittoz gravatar image

updated 2018-11-21 18:21:07 +0100

This might not be the definitive answer, so check you specific case.

You have defined your Footnote paragraph style as hanging indent formatted, i.e. the left "margin" (called Before Text spacing in the style dialog) some distance to the page margin. You also set the First Line Indent to the negative of this "margin" to align the note number with the page limit.

If you define too narrow an indent, the note number extends within the paragraph "column" and the tab following the number will stop at the next implicit position, which is by default every 0.5" (~1.27 cm).

The fix for this situation is to set the Before Text indent as wide as the largest anticipated note number plus some "buffer" space to get a nice alignment.

However, I don't see clearly the symptom on your screenshots: your Before Text is slightly smaller than 0.5" and the implicitly repeating tab stops seem also to be under 0.5" though larger than Before Text.

edit flag offensive delete link more

Comments

Thank you!

cantrip gravatar imagecantrip ( 2018-11-21 18:27:54 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-21 17:46:25 +0100

Seen: 27 times

Last updated: Nov 21 '18