Ask Your Question
1

libreoffice calc wildcard advanced filter [closed]

asked 2018-11-23 14:41:45 +0100

fck gravatar image

updated 2020-07-23 20:26:07 +0100

Alex Kemp gravatar image

I cannot get calc to filter with the following wildcad condition : "Hom*" (Not with the quotes). When I filter with "Home" it would work fine.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-07-23 20:26:58.525312

1 Answer

Sort by » oldest newest most voted
1

answered 2018-11-23 23:06:33 +0100

m.a.riosv gravatar image

updated 2018-12-02 02:52:01 +0100

Have you selected wildcards in Menu/Tools/Options/LibreOffice calc/Calculate - Enable wildcards in formulas?

By default LO uses regular expressions List of regular expressions more powerfull and complex than wildcards, but when xlsx/xls are opened wildcards are enable.

Edited 20181202

Looks wildcard are only available for functions not for filters, reported a bug:
CALC: Make available wildcards with Standard and Advanced filters like in find & replace.

edit flag offensive delete link more

Comments

Thanks for response. Both "Calculate - Enable wildcards in formulas" and "Search criteria = and <> must apply .." are set as recommended for Excel compatibility. No lines are show. When remove wildcards and filter for say Paul, it works. It works in old xls.

Below is the is my test data and filter a". Agent Product Amount
Paul AA 10
Jan BB 20
Pieter CC 30
Frans BB 40
FILTER
Agent Product Amount *a

Agent Product Amount

fck gravatar imagefck ( 2018-12-01 17:27:31 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2018-11-23 14:41:45 +0100

Seen: 739 times

Last updated: Dec 02 '18