Ask Your Question
0

Cannot saved document located on public samba resources with help LibreOffice 6.1.3 (prev. version open/saved correct) [closed]

asked 2018-11-26 15:38:38 +0100

AlexeyUA gravatar image

updated 2018-12-04 08:44:28 +0100

Hi,

Could you please help me.

LibreOffice 6.0.6.2 does not open files on the samba share. While opening file with machine, which is a client and is working under Lubuntu 18.04, I become error: Common input / output error when accessing /run/user/1000/gvfs/smb-share:server= , share = . Important is, that the same version of LibreOffice opens files on samba share perfectly, if client machine is working under Lubuntu 16.04. By opening file through menu of LibreOffice: File→Open I see samba share and can open files only for reading. Installing of most earlier versions of LibreOffice does not take effect.

On Lubuntu 16.04 by default works samba 4.3.2. Lubuntu 18.04 installs by default libsmbclient and samba libraries of version 4.7.6. Downgrade to earlier versions of samba is impossible.

Ps. Downgrade to earlier version of Lubuntu is impossible too, because hardware of PC is to new and Lubuntu 16.04 is working incorrectly.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by AlexeyUA
close date 2018-11-26 16:24:34.363044

Comments

Not clear why did you close it as not relevant, but it's possibly tdf#115747.

Mike Kaganski gravatar imageMike Kaganski ( 2018-11-28 10:50:14 +0100 )edit

I cannot remake this situation. i do No know, but in 2 days, documents were correctly opened and saved on the samba share.

AlexeyUA gravatar imageAlexeyUA ( 2018-11-28 14:28:26 +0100 )edit

samba Version 4.3.11-Ubuntu

Client Ubuntu Ubuntu 14.04.5 LTS \n \l 4.4.0-138-generic

//192.168.1.57/Share2 /media/user/Share2 cifs username=,password=,rw,uid=1000,gid=1000,_netdev 0 0

Error saving the document <file>: Error creating object.

AlexeyUA gravatar imageAlexeyUA ( 2018-12-04 09:41:34 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-11-26 15:54:34 +0100

AlexeyUA gravatar image

updated 2018-12-04 09:41:49 +0100

I have found and applied one temproary solution:

in /etc/samba/smb.conf /section GLOBAL/ I have added one string: client max protocol = NT1.

After doing this I am able to open files on the samba share through the menu of LibreOffice: File -> Open. But problem is still there. It is still impossible to open files directly from samba share through pcmanfm.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-11-26 15:38:38 +0100

Seen: 44 times

Last updated: Dec 04