Ask Your Question
1

How do I get Writer module to use "Default Style" only

asked 2018-11-29 05:46:10 +0200

madagascanlemur gravatar image

I did something stupid using "Auto Correct While Typing," but I can't duplicate the mistake to fix it. Paragraphs jump from "Default Style" to "Text Body" and change line spacing. How do I reset to "Default Style" only -- and keep my paragraphs that way?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2018-11-29 08:15:37 +0200

ajlittoz gravatar image

From a methodological point of view, you should never use Default Style for any text you type. Style Default Style is the ancestor of all others and attributes set in it transfer to all other styles unless these attributes are overridden. This is the primary built-in mechanism by which the end-user customises the appearance of his documents.

Main text is supposed to be styled Text Body.

There is glitch (bad design? misconception?) in Writer when you open a new fresh document from File>New. This document is empty (does not derive from a user-template) and starts with undefined contents (it is really empty). Since contents is undefined, the initial paragraph style is also undefined, which falls back to Default Style.

Without any "styling" from your part, your text is then styled Default Style and remains in this style paragraph after paragraph. But if you type any heading with adequate style (Heading n), style for next paragraph will change to Text Body as soon as you hit Enter and will keep with this style afterwards.

I would then recommend you restyle paragraphs in Default Style to Text Body and customise this latter style for the attributes that don't fit your needs.

However, to answer your question, select the paragraphs in the "wrong" style. TextBody should display in the style menu in the toolbar (if it does not display, your selection contains paragraphs with multiple styles). Click on the menu small triangle and scroll to choose Default Style. You're done.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

1

What's worse, sometimes edits in a document might result in a paragraph having that Default Style, even when using styles consistently. E.g., in a document having everything as Text Body, insert a table; put cursor to the end of the table's last cell; press Alt+Enter to add a paragraph after the table (an operation required when you have two tables without an empty paragraph in between). Funny thing that adding a paragraph before the table (Alt+Enter in the first cell) is different.

Mike Kaganski gravatar imageMike Kaganski ( 2018-11-29 08:37:39 +0200 )edit
Mike Kaganski gravatar imageMike Kaganski ( 2018-11-29 08:43:33 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-29 05:46:10 +0200

Seen: 37 times

Last updated: Nov 29 '18