Ask Your Question
0

Spelling Checking Not Working

asked 2018-12-05 14:39:15 +0100

authordave gravatar image

I am using Libre Office Version: 4.4.3.2, Build ID: 40m0(Build:2), Locale: en_US. My OS is Linux Mint 17.2 Cinnamon 64bit. My Spelling Checker does not work in any Mode. I have tried everything I know, including a Google Search for my problem, but no help. Please help.

edit retag flag offensive close merge delete

Comments

  1. Read this tutorial.
  2. If you can’t find an answer, read these guidelines and ask a good question.
gabix gravatar imagegabix ( 2018-12-05 14:45:47 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-12-05 15:25:15 +0100

ajlittoz gravatar image

There are various causes for spell-checker malfunction. The first one is lack of correct language pack, but this must be put aside because you are en_US which is always installed by package managers.

The second one is misconfiguration. You must look in multiple locations.

The most general one is in Tools>Options, Language Settings>Languages. In principle, Western is sync'ed with your OS and should read Default - <your_language> '<your_country>. If this is not the, case fix it. Check there is a check mark with ABC at left of "Default". This means the dictionary and other language tools are installed for this language and national variant.

You can also force another language from the menu (without "Default") but make sure the check mark is here, otherwise spellcheck won't work.

Next, check Default Style configuration (F11 to display the styles side-pane and right-click on it to Modify). Go to the Font tab. Check Language is set to English (USA). If not, push Standard button so that it reverts to Tools>Options setting. Eventually, choose another language, again making sure the check mark is present (no check mark mean the corresponding language pack has not been installed).

If problem still persists, you may have forced (knowingly or not) another language, such as None, with a command or toolbar button. Select the dubious sequence (or select all text) and Tools>Language>For xxx>Reset to Default Language (xxx = selection, paragraph or all text).

If this does not solve your problem, follow @gabix's advice and edit (do not answer) your question to provide more details on what you did and what you expected.

edit flag offensive delete link more

Comments

Thank you ajlittoz. Today something changed? I didn't do anything so I am confused. Your Advice: "check Default Style configuration (F11 to display the styles side-pane and right-click on it to Modify)." - {F11} Never worked before, but now it did!? I didn't change anything, but now my spelling is working :-) Thanks for your advice, which I will copy and save for future reference!

authordave gravatar imageauthordave ( 2018-12-12 14:34:14 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-12-05 14:39:15 +0100

Seen: 24 times

Last updated: Dec 05