Ask Your Question
0

How Can We Turn Off File Locking in the Mac Version?

asked 2019-01-01 01:04:05 +0200

chuanist gravatar image

I would like to turn off file locking, which the ReadMe file describes as on by default. I write with two computers and share files between them via DropBox. Files created with one machine cannot be opened by the other. (!@#$%$#)

The ReadMe file that comes with version 6.1.4.2 for Mac OS advises: ''To disable file locking, edit the soffice script and change the line "export SAL_ENABLE_FILE_LOCKING" to "# export SAL_ENABLE_FILE_LOCKING".

Sounds simple, like configuring PHP. But when I try to edit the soffice file—which I found inside the LibreOffice application package-->contents-->MacOS-->soffice, I do not see ascii text as given in the ReadMe file. Instead, it looks like hex code. And indeed, the system sees the 'soffice' file as a UNIX executable.

There's gotta be a way to do this, right? Can some kind soul tell me how?

edit retag flag offensive close merge delete

Comments

The key to this thing may be a vaguely-worded reference in the directions: '... edit the soffice script ... ' If the 'soffice script' is not the 'soffice' file, then the directions do not give the actual name of the file that needs to be edited.

I have submitted a bug report via Bugzilla in hopes that a knowledgeable eye will examine the directions.

chuanist gravatar imagechuanist ( 2019-01-01 09:19:47 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2019-01-01 11:56:50 +0200

I imagine Mac version is similar to any other version ;-) and as such, the locking would be controlled in the Expert Configuration - I'd look for Locking, and disable UseLocking and/or UseDocumentSystemFileLocking as needed - isn't that what you need?

edit flag offensive delete link more

Comments

Thanks for the interesting and potentially useful recommendation. I did not know about Expert Configuration (which makes Word look positively unsophisticated) so I examined it rather closely.

I did not see references to file locking, locking, or UseDocumentSystemFileLocking, but the entries are many, on many sub-levels, as you know. I will look some more. If I did miss something, maybe someone will steer me to it.

This morning I found an e-mail from Bugzilla confirming my bug report.

chuanist gravatar imagechuanist ( 2019-01-01 18:08:57 +0200 )edit

As you mentioned using 6.1.4.2, there must be a search box in the expert configuration dialog. There is the search term is to be entered, which was meant by "I'd look for Locking" words.

This morning I found an e-mail from Bugzilla confirming my bug report

Please mention the bug report link here.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-01 20:06:46 +0200 )edit

Mike—

Thanks. As it turns out, you were right. A second search in Expert Configuration turned up:

—org.openoffice.Office.Common -->Misc-->UseLocking; UseDocumentOOoLockFile; UseDocumentSystemFileLock

Setting all three parameters to 'false' lets Writer files be opened and edited on other machines.

I am happy to let my Bugzilla bug report stand, because the instructions for turning off file locking in the Readme file will not get you where you need to go.

chuanist gravatar imagechuanist ( 2019-01-02 00:00:19 +0200 )edit

That looks to have been BZ issue tdf#122399

vsfoote gravatar imagevsfoote ( 2019-06-10 15:25:14 +0200 )edit
0

answered 2019-01-01 06:22:17 +0200

chuanist gravatar image

Thanks for the interesting suggestion. I turned off hidden files in the command line, then searched high and low, including application support-->LibreOffice in the user's library.

Nada.

The Mac only has 'soffice' in 'Applications-->LibreOffice-->Contents-->MacOS-->soffice' No 'soffice.bin', and no text file named 'soffice'.

It looks like I am still confronted by a hex file that has no obvious way to identify or alter the relevant code section.

edit flag offensive delete link more

Comments

Perhaps you might revisit the question you asked on the AOO forum a year ago - there may be something there that helps.

robleyd gravatar imagerobleyd ( 2019-01-01 06:44:54 +0200 )edit

I wish there was! On the AOO forum, RoryOF seemed to think I was describing a system problem, when I was not. None of the responses there touch on what I have described here (I just looked again). Sadly, as much as I would like to adopt Writer (LO or AOO) as my primary writing tool, default file locking prevents it.

Shouldn't file locking be a checkbox or button in the Preferences Pane?

I check in every so often to see if either version of Writer has changed, but alas. AOO for Mac is still in the same version as when I posted on that forum. LO Writer is a whole version advanced, but someone still thinks that file locking should be on by default.

This is a sticky problem. AOO gives the same advice for turning off file locking as LO, and it is equally impossible for Mac users.

chuanist gravatar imagechuanist ( 2019-01-01 07:06:06 +0200 )edit
0

answered 2019-01-01 02:52:39 +0200

robleyd gravatar image

I imagine the Mac version is similar to the Linux version; Linux has soffice and soffice.bin. The former is a shell script and the latter is an ELF executable. Perhaps if you set your file manager to show file extensions, or look from the command line, you may see both.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-01 01:04:05 +0200

Seen: 61 times

Last updated: Jan 01