Ask Your Question
0

importing csv skip ID column

asked 2019-01-02 21:42:15 +0100

libreofficeguy gravatar image

hi guys, I am new to base and made a new table by importing a csv file. then afterward I tried to import another csv file by opening it in calc and copying the data row. when I paste it in base and get the pasting wizard popup I continue to "assign columns" and I notice that base is matching the first value with the ID column. I of course want to to skip the ID column since it is autonumbering, I want base to match the data starting at the second column. Is there a way to do this?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-01-02 22:05:10 +0100

Ratslinger gravatar image

Hello,

It appears you are simply trying to add more data to an existing table. Just copy the column(s) with the wanted data (not the ID column) and paste that. Then insure the added data lines up with the existing column for the table.

edit flag offensive delete link more

Comments

here is a picture to clarify some more https://imgur.com/a/zIiJd3Q

See how when I select food name on the source table it selects food ID on the right. that's because the destination table has an extra ID column. Now here is the thing, 1. I cannot move the ID down for some reason, the only way I can do it is by moving all the values below above ID one by one, I have a lot of them. Doing this for every import would be highly inefficient. Any ideas?

libreofficeguy gravatar imagelibreofficeguy ( 2019-01-07 10:00:46 +0100 )edit

update: I managed to move the ID column to the back by copying and pasting my DB and then moving it in the paste wizard. But now i get the error "Wrong data type: java.lang.NumberFormatException: Too many nonzero exponent digits.". It is probably because the ID is not generating the autovalues when the data is added...

libreofficeguy gravatar imagelibreofficeguy ( 2019-01-07 13:15:39 +0100 )edit

Have tried numerous ways to reproduce you error but can't. Here is a simpler method. Go back to the original 'copy/paste' with the ID column. When you get to the Assign columns window, remove the check mark from the Source 'ID' field, then create. Insure your table definition is set for this field to be an autovalue field.

Ratslinger gravatar imageRatslinger ( 2019-01-07 18:46:55 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-02 21:42:15 +0100

Seen: 40 times

Last updated: Jan 02