Ask Your Question
1

spreadsheet, how to show gridlines

asked 2019-01-03 12:47:39 +0200

rossb2 gravatar image

updated 2019-01-09 12:57:51 +0200

I have exported a spreadsheet from Apple Numbers, in xlsx format. All the data and formulas are there, but there are no gridlines. How do you put the spreadsheet gridlines back on?C:\fakepath\contract search.ods

edit retag flag offensive close merge delete

Comments

If the answer below doesn't help, please supply an example file showing the problem for you.

Lupp gravatar imageLupp ( 2019-01-03 13:24:57 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2019-01-09 13:03:54 +0200

updated 2019-01-09 13:08:15 +0200

Your document has background set to White. Coloured background suppresses display of gridlines, only explicit borders would be visible for such cells.

In some places, your borders are also explicitly set - to white. Then, these cells will never show you gridlines for obvious reasons (even with "Show on coloured cells enabled).

You may select everything and set background to None, and borders to none. Or you could reset direct formatting (but that would also remove other kinds of formatting, like explicit number formatting applied).

edit flag offensive delete link more

Comments

thanks. I was able to fix, by running "clear direct formatting" on the format menu, so resetting direct formatting as suggested helped. This produced a blank spreadheet. I then set options/libreoffice calc/view/grid lines to show, and it is back to how it should be. The fix was actually a combination of the ideas suggested by Lupp and Mike

rossb2 gravatar imagerossb2 ( 2019-01-11 11:41:53 +0200 )edit
1

answered 2019-01-03 13:23:53 +0200

Lupp gravatar image

First of all save the document to an .ods file.
Make sure under >Tools>Options> LibreOffice Calc>View>VisualAids to have chosen "Show on coloured cells" (meaning "...also on...").
If some of the sheets or all of them still don't show grid lines, open the sheet tab's context menu for every sheet concerned, and select 'View Grid Lines' there. The little icon left of the text should show chosen then.

edit flag offensive delete link more

Comments

I have set the options for calc to "show on coloured cells", for the grid lines, as you suggest. I am not clear on the second point though, "If some of the sheets or all of them still don't show grid lines, open the sheet tab's context menu for every sheet concerned, and select 'View Grid Lines' there. The little icon left of the text should show chosen then." where is the sheet tabs context menu?

rossb2 gravatar imagerossb2 ( 2019-01-04 14:42:28 +0200 )edit

Rightclick on the tab.

Lupp gravatar imageLupp ( 2019-01-04 15:27:35 +0200 )edit

thanks. I had a "partial success" on it. I right clicked the sheet tab and selected "grid lines for sheet". The grid lines came on for blank parts of the sheet. They also came on for parts of the cells with text. However some cells still do not have gridlines. Any idea how these can have them added?

rossb2 gravatar imagerossb2 ( 2019-01-07 17:19:35 +0200 )edit

Without an example document showing the issue for you I would just stab in the dark.
Edit your original question and use the toolbar above the editing area. There is an icon looking like a paper-clip which will open the dialogue for attaching.

Lupp gravatar imageLupp ( 2019-01-07 18:29:23 +0200 )edit

thanks. I have uploaded a screen dump.

rossb2 gravatar imagerossb2 ( 2019-01-08 11:49:33 +0200 )edit

Sorry. The image only can show that there are areas without grid lines. It doesn't offer a way to investigate the why.
You should also add information. Your LibO version? Your OperatingSystem?
Your image doesn't even show a title bar of you LibO Window. (This is getting annoying.)

Lupp gravatar imageLupp ( 2019-01-08 12:33:17 +0200 )edit

Thanks. i have attached the document i am having issues with. LibO version 6.0.2.1 OS Mac OS Mojave 10.14

rossb2 gravatar imagerossb2 ( 2019-01-09 12:59:34 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-03 12:47:39 +0200

Seen: 643 times

Last updated: Jan 09