Ask Your Question
0

LO calc: now() shows UTC time, not time in system time zone

asked 2019-01-16 02:36:47 +0200

gbell12 gravatar image

Long time localc user, but a recent upgrade to either LO or my system broke this. If I put =NOW() in a cell, I used to get my local time, now I get UTC time. I'm on Ubuntu 16.04 LTS. /etc/timezone is Australia/Sydney Should localc be respecting the system time zone?

edit retag flag offensive close merge delete

Comments

Have you checked that the locale setting has not been changed? Tools -> Language Settings -> Locale.

ve3oat gravatar imageve3oat ( 2019-01-16 03:31:34 +0200 )edit
2

The LibreOffice locale setting does not influence the result of NOW().

erAck gravatar imageerAck ( 2019-01-16 18:37:18 +0200 )edit

That's good to know. Thanks!

ve3oat gravatar imageve3oat ( 2019-01-16 20:01:58 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-01-16 18:41:06 +0200

erAck gravatar image

updated 2019-01-16 18:43:05 +0200

Check that your user account settings do not override the /etc/timezone location (try in a terminal shell the command date) and a possible shell invoking soffice does not have TZ=UTC set or some such.

edit flag offensive delete link more
-1

answered 2019-06-24 09:33:17 +0200

edit flag offensive delete link more

Comments

User's activity makes impression of possible spam replies. Suggesting some online services for questions that can't be solved by external services.

Mike Kaganski gravatar imageMike Kaganski ( 2019-06-24 09:52:03 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-16 02:36:47 +0200

Seen: 107 times

Last updated: Jun 24