Ask Your Question
0

Edited Quotations style: Complex data (ordered lists, bulleted lists, tables) has incorrect indent

asked 2019-01-18 16:51:37 +0200

mixer gravatar image

I have a file where I copy all the smart/interesting/thought-provoking ideas and information I encounter. Some of them are small (just a few words), while others can be several pages long. Just copy&pasting everything together makes for a very messy result. To help with that, I made modifications to the Quotations style (Indent: 0.8cm before text; border with 0.05cm overall padding; shadow). With plain text everything works nicely:

With plain text everything works nicely

But everything breaks if I use anything more complex such as lists (ordered/bulleted) or tables. So this normal content:

Normal content

Changes into something weird:

Skewed content

Theoretically, all the content has a border around, just like it suppose to have. But in reality, all content has different left margins/indents.

Is there a way to fix this, so all the content would lay beautifully and consistently inside the border?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-01-19 08:44:07 +0200

ajlittoz gravatar image

updated 2019-01-19 10:15:25 +0200

Borders are an attribute of paragraph style. This means that theoretically every paragraph will be "boxed" individually. This would give an ugly look to your text.

To mitigate this, by default, LO merges the borders of identically indented paragraphs, resulting in only the outer border for all the paragraphs. Of course, this is under user control if you prefer individual borders.

You can then achieve what you want by carefully adjusting the indent properties (Indent & spacing tab) of the various styles which are to be part of the same "block". This means you must not use direct formatting (toolbar buttons) but only style modification, notably and mainly for lists.

Lists

Lists are the hard part. You must make sure the base paragraph style (let's say List 1) has exactly the same indents as the "main" paragraph style (usually Text Body). Check that List 1 is fit for list, i.e. it is associated to some list style in the Outline & Numbering tab, List 1.

Then open list style definition and tune the bullet/number and item text positions in the Position tab. Aligned at and Indent at will take precedence on the paragraph style settings (without disturbing them, so that LO Writer still considers they are the same as the surrounding paragraphs) so that your list is laid out as you like.

Tables

I haven't found how to integrate a table inside a group of merged border paragraphs. Tables are not paragraph but objects similar to frames. Therefore they break text flow and cannot be merged, border-wise, with the surrounding paragraphs.

Every cell behaves like some sort of subdocument. Consequently, the recipe given for lists and paragraphs is also valid inside a cell.

Possible workaround

If you know for sure that your "block" is smaller than one page and you add page breaks between "blocks", you can group your chunks inside a frame and you apply border to the frame instead of individual paragraphs. A frame may contain anything: paragraphs, tables, other frames, ...

However this workaround suffers severe shortcomings:

  • Frames can't exceed one page.
  • Anchoring a frame is a nightmare, all the more when you have several in a row.
  • You break normal text flow and editing can become a real burden.
  • You have a tremendous amount of manual work instead of relying on Writer automation.
  • and many more

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-18 16:51:37 +0200

Seen: 51 times

Last updated: Jan 19