I don't know how to repair document with this error Read-Error. Format error discovered in the file in sub-document content.xml at 2,3324(row,col).

asked 2019-01-22 09:59:13 +0100

mtc gravatar image

updated 2019-01-22 10:50:28 +0100

I found some suggestions how to repair it here but I am not sure what should be changed inside the code. this is an libre office document which had some editing done in ms word and i continued working on it in my libre office. after crashing now unable to open the file and this error appears Read-Error. Format error discovered in the file in sub-document content.xml at 2,3324(row,col). I have uploaded the document here https://www.mediafire.com/file/nygh5l... I imagine the error is in the comment from the editor which were made in word . i have worked on this successfully for few days and have been saving regularly the file, but don't have a backup unfortunately. this is an article I have been working on for some time and almost done with editing at which point this happens. I would appreciate help with this. Thank you!

edit retag flag offensive close merge delete

Comments

I assume you don't have a backup; so upload the document on a file sharing service such as Mediafire and post the link here - edit your question. Someone will try and help you.

robleyd gravatar imagerobleyd ( 2019-01-22 10:43:59 +0100 )edit

Thanks robleyd, i have now added link to the doc. much appreciate the help.

mtc gravatar imagemtc ( 2019-01-22 10:51:00 +0100 )edit

Mike, Thank you soooo much! You made my day! Thank you! What did you change in there?

mtc gravatar imagemtc ( 2019-01-22 11:12:36 +0100 )edit

There was a duplicate name attribute, which I had to remove.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-22 11:15:09 +0100 )edit

how do i find it if it happens again? would you be so kind to send me instructions?

mtc gravatar imagemtc ( 2019-01-23 11:19:43 +0100 )edit

Basically I open the document as ZIP, then open the .XML reported in the error message, check it for XML syntax errors, and (given my knowledge of how LO works, since I'm a LO developer) think how to fix that. In case of duplicate attributes that have absolutely same values, it's simply remove all but one duplicating attribute; but in your case, the values of the two duplicates were different, so I had to look around a bit.

It's better that you find the cause of such corruption (which actions/input data/etc give that), and file proper bug report if you encounter it again (but then, you need to use a fresh version, since the problem might be already fixed in a later version).

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-23 12:00:58 +0100 )edit