Ask Your Question
0

[SOLVED] Hyperlinks stop working after I save the document

asked 2019-01-24 19:52:38 +0100

RediDad gravatar image

updated 2019-01-25 13:19:53 +0100

Greetings to all, recently I installed Ubuntu 16.04 on my computer and upgraded Ubuntu to 18.04

With Ubuntu, I started to use LibreOffice which comes with Ubuntu. I am writing a report about ROS and I added lots of Hyperlinks in the document. They are perfectly working when I add them but after saving, closing and re-opening the document they DO NOT work. They look like Hyperlink you know blue, underlined but they just don't work.

I can really use a help, Thanks for anything

Edit: I had a problem with adding tags so if it's in wrong place, I am sorry.

edit retag flag offensive close merge delete

Comments

Doesn't Ctrl+click work?

floris v gravatar imagefloris v ( 2019-01-24 23:15:08 +0100 )edit

I'm afraid it's unclear even which application is used. Is it Writer? Or is the report a presentation in Impress? Or possibly it's a spreadsheet with the report data?

Which is the file format? Do you use native ODF, or some foreign format with possibly sub-optimal support?

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-25 08:39:24 +0100 )edit

When I try to save for the first time, LibreOffice showed me a pop-up and asked me which format. I choose 2003-2007 Microsoft XML file because it was familiar. Can it cause that?

RediDad gravatar imageRediDad ( 2019-01-25 10:44:00 +0100 )edit

DOCX with hyperlinks is opened normally with LO (though it's never wise to use foreign formats for keeping your work). But what is the version of "LibreOffice which comes with Ubuntu"? And what does "they DO NOT work" mean? you seem to not answer to questions of those who try to help you (like the question of @floris v above); do you expect that to make you more friends?

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-25 12:07:47 +0100 )edit

I didn't answer floris v's question because when I said Hyperlinks don't work I meant Ctrl+Click don't work because thats how you work Hyperlinks.

My LibreOffice Version: 6.0.7.3

"they DO NOT work" means when you click them with Ctrl+Click they don't open the connection in that document.

Nope I don't expect make more friends in here although thinking that? Thats not pathetic.

RediDad gravatar imageRediDad ( 2019-01-25 13:18:06 +0100 )edit

I didn't answer floris v's question because when I said Hyperlinks don't work I meant Ctrl+Click don't work because thats how you work Hyperlinks.

Those who answer questions here don't know how familiar you are with LibreOffice, and they meet too often questions that arise just because users don't know that "thats how you work Hyperlinks".

So it's not OK to ignore questions just because you suppose it's natural, or anything. Answering just allows others to rule out that simple possibility, while ignoring makes others feel they're wasting time.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-25 13:32:43 +0100 )edit

@RedDad: thank you for making that clear. I wasted my time on you.

floris v gravatar imagefloris v ( 2019-01-25 23:01:25 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-04-03 20:03:09 +0100

RayN gravatar image

The prior answer is incorrect. I have been using Hyperlinks to local files inside DOCX files for years without trouble.

After testing I found the issue belongs to LibreOffice Writer v6.3.5. Versions 5.3.6.1 & 6.4.2.2 both handle Hyperlinks perfectly, even for documents saved by v6.3.5. Luckily this means once you are ready to upgrade LibreOffice the problem goes away.

If you want details of my tests please let me know.

All the best, Raymond

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-24 19:52:38 +0100

Seen: 801 times

Last updated: Apr 03