Ask Your Question
0

how to remove page number from the last page in writer document

asked 2019-01-27 02:20:46 +0100

Donitsi gravatar image

updated 2019-01-27 09:31:04 +0100

Kruno gravatar image

I need to remove the page number only from the last page of a writer document.

Can you help me please. Thank you :-)

anita

edit retag flag offensive close merge delete

Comments

This can be done if the last has some outstanding property against other pages. If this just the last page of the document, no chance. What is in your last page? Is there a special formatting for the content?

Provide this information with the edit link, not with an answer

ajlittoz gravatar imageajlittoz ( 2019-01-27 08:06:46 +0100 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2019-01-28 00:23:22 +0100

Donitsi gravatar image

Thank you so much to everyone for your answers. I've followed your advise and my problem is now resolved. My last doc page is in a way "irrelevant" to the previous text, but needs to be there just the same.

All is good now. THANK YOU AGAIN :-)))))))

edit flag offensive delete link more

Comments

Then, if the last page is semantically different from the preceding, I'd recommend adding a manual break to a new page style. The page style will be identical to the one used for the main text (likely to be Default Style) but for the footer or header left blank.

This avoids fiddling with Offset property. Offset is meant only for forward/backward references (like "see next page x" or "see 5 pages before at y") which are returned blank is the page does not exist. Using it for offsetting the running page number is a bad practice as advised in several questions on this site.

ajlittoz gravatar imageajlittoz ( 2019-01-28 08:09:44 +0100 )edit
0

answered 2019-01-27 16:17:34 +0100

Grantler gravatar image

updated 2019-01-27 16:20:14 +0100

  • shortcut CTRL + F2 (insert fields)
  • Document > Type Page :: Select Next Page :: Format As Page Style :: Offset -1

Page number is shown in the right way. Last page: Next page is not shown because of not existing. (found here → German wiki archive of OpenOffice)

Be advised that fields don't properly feed a TOC. - Cheers

edit flag offensive delete link more
0

answered 2019-01-27 09:29:18 +0100

Kruno gravatar image

What you should do is create separate page style for only that last page. Click on page style you currently use for your document and go Right Click → New. You want new page style to inherent all formatting from style you currently use. Different page styles get to have different header and footer content. Get cursor to one page before last and do InsertManual break... → [type] Page break → [style] choose style you just created.

Now you should have be able to make last page not having page number.

edit flag offensive delete link more

Comments

Yes, but what is the "last" page? If it's only the consequence of text flow, adding a manual break will not give the expected result if text before the break is edited (may result in an orphan line on the before-last page). This is why I asked about the nature of the last page: a TOC, an index, a back cover? In fact anything but flowing text. We can then identify the beginning of the last page by a specific heading (title) and apply a page break to this paragraph style to switch to the special last-page page style.

ajlittoz gravatar imageajlittoz ( 2019-01-27 09:44:28 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-27 02:20:46 +0100

Seen: 430 times

Last updated: Jan 28