Ask Your Question
0

Import text into Calc. in single column

asked 2019-01-27 18:06:34 +0200

joeh6966 gravatar image

I wish to import this file into calc.. I have edited the list to be comma separated instead of the "|" character. Do I have to add quote characters also? The file looks like this; Parasites Anaplasma Marginale 2nd (XTRA),Parasites Anaplasma marginale: (2nd range) (ETDF),Parasites Anaplasma marginale (ETDF),Parasites Anaplasma Marginale (XTRA),Parasites Ancylostoma braziliense (adult) (ETDF),

It has about 450 items.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2019-01-27 19:01:50 +0200

Ratslinger gravatar image

Hello,

By you separating the fields with commas you have a single record with ~450 columns. You can still use this. Open the file in Calc. With the file extension of .csv or .txt you will get:

image description

Then select OK button and this is result:

image description

Next follow instructions in this post to transpose the data -> Rotating Tables (Transposing)

Result will be, but certainly with more rows:

image description

edit flag offensive delete link more

Comments

I did see that 450 column result the first time that I tried many days ago. However, after trying many times since, nothing happens except a new sheet with nothing on it. Why isn't it possible to get them to Import into one column?

joeh6966 gravatar imagejoeh6966 ( 2019-01-28 20:34:20 +0200 )edit

You can import into one column if the input file is in correct format. One line separated by commas is one record with multiple fields (columns). Each item on a separate line is multiple records (rows) and just one field. It's the nature of your input file.

Don't know what you are doing since your first entry. Insure your Text Import dialog has the correct settings (first image in my answer). Have used your sample data numerous times for testing and always get correct column result.

Ratslinger gravatar imageRatslinger ( 2019-01-28 20:56:43 +0200 )edit

I was trying for row 2 every time, but then today I put it to row 1 and yes, it works. Thanks for your help. So, to take a comma separated list or one with "|"s, I would need to edit it to make a single file column first before importing it? I think that your method was easier.

joeh6966 gravatar imagejoeh6966 ( 2019-01-31 23:09:46 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-27 18:06:34 +0200

Seen: 86 times

Last updated: Jan 27