Ask Your Question
0

Control-Shift-S doesn't open Special Characters

asked 2019-01-31 13:55:07 +0200

sanitycheck gravatar image

In my Windows 10 OS, with LibreOffice Writer open, when I hit Control-Shift-S, instead of opening the Special Characters dialogue, it gives me the Save As dialogue. Why?

edit retag flag offensive close merge delete

Comments

Ctrl+Shift+S is the default keyboard mapping for "Save As"

BigRAl gravatar imageBigRAl ( 2019-01-31 14:01:30 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-01-31 16:07:25 +0200

Platterbaff gravatar image

updated 2019-02-01 15:15:06 +0200

You don't say what OS and LO version you are using, but you seem to come across something that has gone wrong.

In Windows 7/Writer 6.0,7.3, at least, Ctrl+Shift+S does indeed, as BigRAl points out, produce the Save As dialog. [But so does Ctrl+S] See addendum below

However, LO help at https://help.libreoffice.org/Common/G... says "Use the shortcut keys Ctrl+Shift+S to open the Special Characters dialog to insert one or more special characters." [and "Ctrl+S Saves the current document] See addendum below..

I can only suggest that you report this at Bugzilla where it might be related to Bug 95442. You can of course also try customizing your shortcuts as advised in Chapter 21: Customizing Writer of the Writer Guide 6 as a stopgap until this problem (if confirmed) is sorted out.

Addendum

I have annotated points above to take account of Mike Kaganski's comments pointing out that part of my reply was wrong, but have left my mistake in place so that any newcomers can make sense of the contributions. Please ignore the parts in square brackets.

But it still seems that we have a problem with documentation not agreeing with what Ctrl+Shift+S actually does. And perhaps with not having a pre-set keyboard combination for Special Characters, which touch-typists might well want.

edit flag offensive delete link more

Comments

Ctrl+Shift+S does indeed, as BigRAl points out, produce the Save As dialog. But so does Ctrl+S

Not exactly. Ctrl+S just saves (not saves as) without dialog, if the file already has a name; only when it's yet unnamed file, it brings the dialog.

OTOH, Ctrl+Shift+S is specifically Save As (of course, we talk about default key mappings).

However, LO help at ... says "Use the shortcut keys Ctrl+Shift+S to open the Special Characters dialog to insert one or more special characters."

That is a section named "Practical Text Input Fields". And interestingly, in text input fields, e.g. in Find toolbar, it indeed opens the Special Chars dialog. The shortcut clash is possibly something to report and fix.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-31 16:09:52 +0200 )edit

Ah, very sorry. I made the elementary mistake of checking only an unsaved document.

But we still seem to have something that needs to be sorted out to make sure that our shortcuts and their documentation are entirely consistent. And this should include one for Special Characters.

Platterbaff gravatar imagePlatterbaff ( 2019-01-31 16:19:03 +0200 )edit
0

answered 2019-01-31 15:30:31 +0200

vsfoote gravatar image

That has never been a defined shortcut for the Symbol/Special Character dialog. But, you can assign it to be used in Writer via the Tool -> Customize dialog's "keyboard" panel.

Open that (note it is modal, for either all of LibreOffice or just the launching module), search for the key combination you'd like to assign and select. The enter "Symbol" in the search field. It will return

Symbol Symbol Symbol Shapes

You want to assign the first one (possible the 2nd if it sorts differently) by using the"Modify" button. OK out to save and close dialog.

You'll know it is correct when back in Writer, you usse the newly assigned shortcut and the dialog opens.

Hope that helps...

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2019-01-31 13:55:07 +0200

Seen: 49 times

Last updated: Feb 01