Ask Your Question
0

How do you get table data displayed in a form?

asked 2019-01-31 15:14:50 +0100

wblueg gravatar image

I have a filtered Base table displayed in the 'Data Sources' box of a Form. How do I get the data to display in the form for editing? There are 36 records in the filtered table.
I want to edit data in each record and step to the next record. I think I may have an improper control setting somewhere but I have looked everywhere and punched all of the buttons. If it helps, this table is used for language translation and the data is text. It is destined to become a research document source for various presentation modes.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-01-31 19:58:03 +0100

Ratslinger gravatar image

updated 2019-02-04 06:09:19 +0100

Hello,

First you start with a form which can display and modify your tables' data:

image description

It matters no whether you are using individual fields or a table control. With individual fields you will want either a Navigator control on the form or turn on the toolbar item - View->Toolbars select Form Navigation.

Now you can setData Source as Table on. Then from that section select `Standard Filter icon giving:

image description

Then you choose the wanted filtering and select OK.

image description

Now your form is filtered for only those records and they can be modified and saved. Again, if you are using individual fields, the navigation bar will allow you to go to next, first, last, prior records within the filtered records.

Edit 2019-02-03:

Here is image of icon on tool bar for Form Filter:

image description

If your form is not wide enough to display all the icons on the toolbar, there is >> on the right edge of the toolbar (this is a standard method). Select for remainder of icons.

When selected you get: image description

edit flag offensive delete link more

Comments

First, this is where I was when I asked the question except that the filtered data does not fill the form as it does in your example. Second, your example toolbars are not like those of my form. How can I get the GUI that you are using? Mine doesn't have the navigation bar. It does have a Filter Navigator box but it doesn't seem to be connected to anything.

wblueg gravatar imagewblueg ( 2019-02-03 20:50:26 +0100 )edit

@wblueg Toolbars contain the same functions, but depending on how you have set your options, the icons may be different looking. They function identically. As mentioned in my answer, The navigation bar, if not already visible, can be made visible from the menu item View->Toolbars select Form Navigation. Also, I don't see where you ever mentioned which version of LO you are using? I do think you are on a Mac. Is that correct?

Ratslinger gravatar imageRatslinger ( 2019-02-03 22:41:21 +0100 )edit

Yes to the Mac. Form Navigation does not produce a tool bar similar to yours. It does produce a tool bar allowing only Record Search. This works. All other sorting, filtering, etc functions are greyed out.

wblueg gravatar imagewblueg ( 2019-02-03 23:06:56 +0100 )edit

V: 6.0.7.3

wblueg gravatar imagewblueg ( 2019-02-03 23:13:19 +0100 )edit

It appears you have the form open in Edit mode. Records cannot be navigated from there. Records cannot be accessed from there ether. Close and then open from main .odb by double clicking the form name.

Ratslinger gravatar imageRatslinger ( 2019-02-03 23:14:39 +0100 )edit

You are right. Had it in edit mode. Been in and out of there all day. Sorry I didn't catch that. When in the working (?) mode the Filter navigator box comes up.
It appears that I am missing the 'Apply Form-Based Filter' Icon. Switching to the unfiltered view does show Base records and things work fine. But - its the filtered data I work in and the boxes are blank in the 'user' mode.

wblueg gravatar imagewblueg ( 2019-02-03 23:39:07 +0100 )edit

This is where the original question needed better information. The Form-Based Filters is on the Navigation bar and not in Data Sources as you pointed to in the question. Data Sources uses the standard filter only, this usage shown in my answer. You may also want to see this post -> BASE - Form Filter on Subform

Also, here is the link to the LO Base documentation -> LibreOffice Base Handbook

Ratslinger gravatar imageRatslinger ( 2019-02-03 23:59:16 +0100 )edit

By using the filter box in the Form Properties dialog I can get the desired results for now. I don’t know how this works longtime.

I am not able to find the Form-Based Filter icon in the Form Filter toolbar. I hesitate to say there is a glitch but - - it don’t wurk fur me. Following the suggested documentation did not make it appear.

wblueg gravatar imagewblueg ( 2019-02-04 05:40:05 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-31 15:14:50 +0100

Seen: 32 times

Last updated: Feb 04