Ask Your Question
0

Not all installed fonts show in the drop-down list

asked 2019-02-02 03:48:57 +0200

Z300M gravatar image

updated 2019-02-02 19:27:19 +0200

LibreTraining gravatar image

I have the following Minion Pro fonts installed in my Manjaro Linux machine:

MinionPro-Regular.otf
MinionPro-It.otf
MinionPro-Bold.otf
MinionPro-BoldIt.otf

MinionPro-Medium.otf
MinionPro-MediumIt.otf

MinionPro-Semibold.otf
MinionPro-SemiboldIt.otf

MinionPro-BoldCn.otf
MinionPro-BoldCnIt.otf

but the only ones that show in the drop-down list are:

Minion Pro
Minion Pro Cond
Minion Pro Med
Minion Pro SmBd

What happened to the others?

edit retag flag offensive close merge delete

Comments

The serious practical effect of this is that I cannot create a style that changes text from Minion Pro Med to Minion Pro Bold: Bold is not a "Font Effect," and Minion Pro Bold does not appear in the list of fonts when defining a Style unless I select Minion Pro as the "base font" instead of Minion Pro Med.

BUT comparing "bolded" (using Ctrl-B or the button) Minion Pro Med with actual Minion Pro Bold, the latter looks "cleaner." The "bolded" Minion Pro Med looks "fuzzier," as though all the lines of Minion Pro Med have been thickened instead of Minion Pro Bold being selected automatically.

I really do miss WordPerfect with its user-defined substitution tables -- far more customization than LO offers,

Z300M gravatar imageZ300M ( 2019-02-02 21:40:37 +0200 )edit

There is no bold medium font.
So it is faked.
Which is why it looks bad.
Which is why I cautioned to not do that.

I do not understand why you cannot assign the Bold font to a style.

LibreTraining gravatar imageLibreTraining ( 2019-02-03 06:55:24 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-02-02 20:31:27 +0200

LibreTraining gravatar image

Those fairly old fonts use styling groups (R/I/B/BI) so you may be able to select them the same as in LO on Windows.
For example selecting Minion Pro from the font list gives you Regular.
Then you use the Italic and the Bold buttons to select the other styles.

The Condensed, Medium, and SemiBold are separate styling groups.
Select those in the font list for the Regular, and then use the Italic button to get the italic style.
Be aware that using the Bold and Italic buttons when a font is not installed will give you a faked font.
I check the actual fonts in the PDF output to be sure it is working properly.

This works in LO on Windows with these fonts in my tests.

image description

.

You may also be able to select the font styles using the Character dialog.

image description

.

I know this works differently on Linux vs. Windows so this may or may not work for you.

Please come back and post your results.

.

edit flag offensive delete link more
0

answered 2019-02-02 10:16:42 +0200

RGB-es gravatar image

See here:

Bug 35538 - Handling of fonts with more that 4 styles (R/B/I/BI) is suboptimal

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2019-02-02 03:48:57 +0200

Seen: 83 times

Last updated: Feb 02