Ask Your Question
0

LO Calc ignores OS "short date" format [closed]

asked 2019-02-11 06:34:06 +0100

RichPasco gravatar image

updated 2019-02-12 14:48:21 +0100

On the Region and Language page of my Windows control panel, I have chosen English (United States) and customized the "Short date" format to the ISO 8601 format yyyy-MM-dd as shown here:

Region and Language

MS Excel supports spreadsheet cells set to use the OS regional short date format. Notice the asterisk and footnote here:

MS Excel Format Cells

and so MS Excel displays these cells thusly:

MS Excel Display

But when opening such an XLS file, LibreOffice Calc disregards any custom short date format. Notice there is no asterisk here:

LO Calc Format Cells

and instead displays such cells in the traditional USA format M/d/yyyy format, like this:

LO Calc Display

Okay, the obvious work-around is to forget about the asterisk-ed setting in MS Excel, and instead forcibly select the yyyy-MM-dd format (without the asterisk). This would ensure portability of my XLS file between MS Excel and LO Calc, but then it would disregard the preference of other users to whom I might send it, who would have their OS "short date" format set differently from mine. Is there any way to get LO Calc to respect the OS "short date" setting?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by erAck
close date 2019-02-12 16:37:11.119599

1 Answer

Sort by » oldest newest most voted
1

answered 2019-02-11 19:58:57 +0100

erAck gravatar image

Short answer: No. Long answer: it's an RFE.

edit flag offensive delete link more

Comments

Thanks, erAck. Of course, I am disappointed that I can't do what I want right away, but pleased that I am not the only one to notice this shortfall and request that it be remedied.

RichPasco gravatar imageRichPasco ( 2019-02-11 22:14:49 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2019-02-11 06:34:06 +0100

Seen: 41 times

Last updated: Feb 12